Search path environment variables for cross-compilers. See the discussion at . Note: Touch 'C_INCLUDE_PATH' et al. rather than 'CPATH', as discussed at . diff --git a/gcc/gcc.c b/gcc/gcc.c --- a/gcc/gcc.c +++ b/gcc/gcc.c @@ -4474,7 +4474,7 @@ process_command (unsigned int decoded_options_count, } temp = env.get (LIBRARY_PATH_ENV); - if (temp && *cross_compile == '0') + if (temp) { const char *startp, *endp; char *nstore = (char *) alloca (strlen (temp) + 3); diff --git a/gcc/incpath.c b/gcc/incpath.c --- a/gcc/incpath.c +++ b/gcc/incpath.c @@ -472,8 +472,8 @@ register_include_chains (cpp_reader *pfile, const char *sysroot, int stdinc, int cxx_stdinc, int verbose) { static const char *const lang_env_vars[] = - { "C_INCLUDE_PATH", "CPLUS_INCLUDE_PATH", - "OBJC_INCLUDE_PATH", "OBJCPLUS_INCLUDE_PATH" }; + { "CROSS_C_INCLUDE_PATH", "CROSS_CPLUS_INCLUDE_PATH", + "CROSS_OBJC_INCLUDE_PATH", "CROSS_OBJCPLUS_INCLUDE_PATH" }; cpp_options *cpp_opts = cpp_get_options (pfile); size_t idx = (cpp_opts->objc ? 2: 0); @@ -484,7 +484,7 @@ register_include_chains (cpp_reader *pfile, const char *sysroot, /* CPATH and language-dependent environment variables may add to the include chain. */ - add_env_var_paths ("CPATH", INC_BRACKET); + add_env_var_paths ("CROSS_CPATH", INC_BRACKET); add_env_var_paths (lang_env_vars[idx], INC_SYSTEM); target_c_incpath.extra_pre_includes (sysroot, iprefix, stdinc); diff --git a/gcc/system.h b/gcc/system.h --- a/gcc/system.h +++ b/gcc/system.h @@ -1244,4 +1244,6 @@ void gcc_stablesort (void *, size_t, size_t, of the number. */ #define PRsa(n) "%" #n PRIu64 "%c" +#define LIBRARY_PATH_ENV "CROSS_LIBRARY_PATH" + #endif /* ! GCC_SYSTEM_H */ /tr>
path: root/NEWS
AgeCommit message (Expand)Author
2021-11-23Update NEWS.Ludovic Courtès
2021-09-23Update NEWS....* NEWS (Distribution): Note new fsck.* arguments and XFS support. Tobias Geerinckx-Rice
2021-09-18Update NEWS.Ludovic Courtès
2021-07-07guix-install.sh: Prompt for configuring substitutes discovery....Also ensure prompt_yes_no always print the message with a trailing space, which is more pleasing to the eye. * etc/guix-daemon.conf.in <--discover=no>: New guix-daemon option. * etc/guix-daemon.service.in: Likewise. * etc/init.d/guix-daemon.in: Likewise. * etc/openrc/guix-daemon.in: Likewise. * etc/guix-install.sh (configure_substitute_discovery): New procedure. (sys_enable_guix_daemon): Ask the user whether automatic substitute discovery should be enabled. Set the '--discover' argument accordingly. (prompt_yes_no): Add a trailing space to the message. (sys_authorize_build_farms): Remove trailing space from the message argument. * NEWS (Distribution): Add news. Maxim Cournoyer
2021-06-29pack: Add support for the deb format....* .dir-locals.el (scheme-mode)[gexp->derivation]: Define indentation rule. * guix/scripts/pack.scm (debian-archive): New procedure. (%formats): Register the new deb format. (show-formats): Add it to the usage string. * tests/pack.scm (%ar-bootstrap): New variable. (deb archive with symlinks): New test. * doc/guix.texi (Invoking guix pack): Document it. * NEWS: Add news entry. Maxim Cournoyer
2021-05-10Update NEWS.Maxim Cournoyer
2021-05-10Update NEWS.Leo Famulari
2021-05-10Update NEWS.Ludovic Courtès
2021-05-04Update NEWS.Ludovic Courtès
2020-11-22Update NEWS.Ludovic Courtès
2020-11-13Update NEWS.Ludovic Courtès
2020-11-09Update NEWS.Ludovic Courtès
2020-11-07Update NEWS.Mathieu Othacehe
2020-11-07Update NEWS.Ludovic Courtès
2020-11-05Update NEWS.Ludovic Courtès
2020-04-15Update NEWS.Ludovic Courtès
2020-04-12Update NEWS.Ludovic Courtès
2020-04-09Update NEWS.Ludovic Courtès