As for libc's `system', change Awk to look for `sh' in $PATH. This patch is only meant to be used during bootstrapping, where we don't know in advance the absolute file name of `sh'. --- gawk-4.1.3/io.c 2015-05-19 15:37:20.000000000 +0200 +++ gawk-4.1.3/io.c 2015-06-09 18:39:36.918414881 +0200 @@ -2025,7 +2025,7 @@ set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", command, NULL); + execlp("sh", "sh", "-c", command, NULL); _exit(errno == ENOENT ? 127 : 126); case -1: @@ -2077,7 +2077,7 @@ signal(SIGPIPE, SIG_DFL); - execl("/bin/sh", "sh", "-c", command, NULL); + execlp("sh", "sh", "-c", command, NULL); _exit(errno == ENOENT ? 127 : 126); case -1: @@ -2422,7 +2422,7 @@ fatal(_("close of pipe failed (%s)"), strerror(errno)); /* stderr does NOT get dup'ed onto child's stdout */ set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", str, NULL); + execlp("sh", "sh", "-c", str, NULL); _exit(errno == ENOENT ? 127 : 126); } #endif /* NOT __EMX__, NOT __MINGW32__ */ @@ -2659,7 +2659,7 @@ if (close(p[0]) == -1 || close(p[1]) == -1) fatal(_("close of pipe failed (%s)"), strerror(errno)); set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", cmd, NULL); + execlp("sh", "sh", "-c", cmd, NULL); _exit(errno == ENOENT ? 127 : 126); } #endif /* NOT __EMX__, NOT __MINGW32__ */ 6e95b2205742e1204d174ce9156742a4c39776b'>commitdiff
path: root/po
AgeCommit message (Collapse)Author
2023-06-30nls: Update translations.Florian Pelz
* po/packages/ja.po: New file. * po/packages/LINGUAS: Add it.
2023-06-18Add 'guix locate'.Ludovic Courtès
* guix/scripts/locate.scm, tests/guix-locate.sh: New files. * Makefile.am (MODULES): Add 'guix/scripts/locate.scm'. (SH_TESTS): Add 'tests/guix-locate.sh'. * po/guix/POTFILES.in: Add it. * doc/guix.texi (Invoking guix locate): New node. Co-authored-by: Antoine R. Dumont <antoine.romain.dumont@gmail.com>
2023-05-31nls: Update translation keys for guix gc.Remco van 't Veer
* po/*/*.po (guix/scripts/gc.scm): Round MiBs in user feedback. Signed-off-by: Florian Pelz <pelzflorian@pelzflorian.de>
2023-05-31nls: Update translations.Florian Pelz
* doc/guix-cookbook.texi (Top): Mention Slovak.
2023-04-08nls: Make sure gnu/home/services/*.scm files are translatable.Ludovic Courtès
* po/guix/POTFILES.in: Add missing gnu/home/services/*.scm files.