As for libc's `system', change Awk to look for `sh' in $PATH. This patch is only meant to be used during bootstrapping, where we don't know in advance the absolute file name of `sh'. --- gawk-4.1.3/io.c 2015-05-19 15:37:20.000000000 +0200 +++ gawk-4.1.3/io.c 2015-06-09 18:39:36.918414881 +0200 @@ -2025,7 +2025,7 @@ set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", command, NULL); + execlp("sh", "sh", "-c", command, NULL); _exit(errno == ENOENT ? 127 : 126); case -1: @@ -2077,7 +2077,7 @@ signal(SIGPIPE, SIG_DFL); - execl("/bin/sh", "sh", "-c", command, NULL); + execlp("sh", "sh", "-c", command, NULL); _exit(errno == ENOENT ? 127 : 126); case -1: @@ -2422,7 +2422,7 @@ fatal(_("close of pipe failed (%s)"), strerror(errno)); /* stderr does NOT get dup'ed onto child's stdout */ set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", str, NULL); + execlp("sh", "sh", "-c", str, NULL); _exit(errno == ENOENT ? 127 : 126); } #endif /* NOT __EMX__, NOT __MINGW32__ */ @@ -2659,7 +2659,7 @@ if (close(p[0]) == -1 || close(p[1]) == -1) fatal(_("close of pipe failed (%s)"), strerror(errno)); set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", cmd, NULL); + execlp("sh", "sh", "-c", cmd, NULL); _exit(errno == ENOENT ? 127 : 126); } #endif /* NOT __EMX__, NOT __MINGW32__ */ efd9313362e7'>commitdiff
path: root/.gitignore
AgeCommit message (Expand)Author
2022-07-03etc: Add teams.scm....Ricardo Wurmus
2022-06-05gitignore: Add .DS_Store....Pavel Shlyak
2021-10-16.gitignore: Ignore more autotools directories....Sarah Morgensen
2021-10-16.gitignore: Ignore more temporary test directories....Sarah Morgensen
2021-09-20etc: Add systemd files for running ‘guix gc’ periodically...Thiago Jung Bauermann
2021-05-10.gitignore: Ignore .mo files....Maxim Cournoyer
2021-05-05.gitignore: Ignore .tarball-ignore....Maxim Cournoyer
2021-04-23.gitignore: Ignore release artifacts....Maxim Cournoyer
2021-04-23.gitignore: Ignore generated .pot files....Maxim Cournoyer
2020-10-20gitignore: Ignore generated guile binary and intermediate products....Julien Lepiller
2020-09-17guix-install.sh: Support OpenRC....Morgan Smith
2020-07-17gitignore: Don't ignore daemon source code....Jakub Kądziołka
2020-06-28.gitignore: Ignore 'etc/committer.scm'....Brice Waegeneire
2020-05-16etc: Add a systemd unit to bind-mount @storedir@ read-only....Tobias Geerinckx-Rice
2020-05-14etc: indent-code.el: Use the --quick option....Maxim Cournoyer
2020-03-30.gitignore: Ignore test results in tests/services....Marius Bakke
2020-03-11Add system start-up files for guix-daemon....Danny Milosavljevic