As for libc's `system', change Awk to look for `sh' in $PATH. This patch is
only meant to be used during bootstrapping, where we don't know in advance the
absolute file name of `sh'.
--- gawk-4.1.3/io.c 2015-05-19 15:37:20.000000000 +0200
+++ gawk-4.1.3/io.c 2015-06-09 18:39:36.918414881 +0200
@@ -2025,7 +2025,7 @@
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", command, NULL);
+ execlp("sh", "sh", "-c", command, NULL);
_exit(errno == ENOENT ? 127 : 126);
case -1:
@@ -2077,7 +2077,7 @@
signal(SIGPIPE, SIG_DFL);
- execl("/bin/sh", "sh", "-c", command, NULL);
+ execlp("sh", "sh", "-c", command, NULL);
_exit(errno == ENOENT ? 127 : 126);
case -1:
@@ -2422,7 +2422,7 @@
fatal(_("close of pipe failed (%s)"), strerror(errno));
/* stderr does NOT get dup'ed onto child's stdout */
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", str, NULL);
+ execlp("sh", "sh", "-c", str, NULL);
_exit(errno == ENOENT ? 127 : 126);
}
#endif /* NOT __EMX__, NOT __MINGW32__ */
@@ -2659,7 +2659,7 @@
if (close(p[0]) == -1 || close(p[1]) == -1)
fatal(_("close of pipe failed (%s)"), strerror(errno));
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", cmd, NULL);
+ execlp("sh", "sh", "-c", cmd, NULL);
_exit(errno == ENOENT ? 127 : 126);
}
#endif /* NOT __EMX__, NOT __MINGW32__ */
ckages/tv.scm?id=9396fef40998ba6b580b2d6c5c7b774b7a6ccd1e'>commitdiff
|
Age | Commit message (Expand) | Author |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2020-10-06 | gnu: Fix up package copyright headers. | Tobias Geerinckx-Rice |
2018-11-11 | gnu: tvtime: Fix building with glibc@2.28....* gnu/packages/tvtime.scm (tvtime)[arguments]: Add custom phase to add
missing import.
| Efraim Flashner |
2018-03-24 | gnu: tvtime: Fix build....* gnu/packages/tv.scm (tvtime)[native-inputs]: Add 'pkg-config' to avoid
compilation errors.
| Alex Kost |
2017-01-28 | gnu: tvtime: Update to 1.0.11....* gnu/packages/tv.scm (tvtime): Update to 1.0.11.
| Alex Kost |
2016-05-04 | gnu: tvtime: Update to 1.0.10....* gnu/packages/tv.scm (tvtime): Update to 1.0.10.
[source]: Remove patches.
[inputs]: Add 'alsa-lib'.
* gnu/packages/patches/tvtime-gcc41.patch,
gnu/packages/patches/tvtime-pngoutput.patch,
gnu/packages/patches/tvtime-videodev2.patch,
gnu/packages/patches/tvtime-xmltv.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Remove them.
| Alex Kost |