As for libc's `system', change Awk to look for `sh' in $PATH. This patch is
only meant to be used during bootstrapping, where we don't know in advance the
absolute file name of `sh'.
--- gawk-4.1.3/io.c 2015-05-19 15:37:20.000000000 +0200
+++ gawk-4.1.3/io.c 2015-06-09 18:39:36.918414881 +0200
@@ -2025,7 +2025,7 @@
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", command, NULL);
+ execlp("sh", "sh", "-c", command, NULL);
_exit(errno == ENOENT ? 127 : 126);
case -1:
@@ -2077,7 +2077,7 @@
signal(SIGPIPE, SIG_DFL);
- execl("/bin/sh", "sh", "-c", command, NULL);
+ execlp("sh", "sh", "-c", command, NULL);
_exit(errno == ENOENT ? 127 : 126);
case -1:
@@ -2422,7 +2422,7 @@
fatal(_("close of pipe failed (%s)"), strerror(errno));
/* stderr does NOT get dup'ed onto child's stdout */
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", str, NULL);
+ execlp("sh", "sh", "-c", str, NULL);
_exit(errno == ENOENT ? 127 : 126);
}
#endif /* NOT __EMX__, NOT __MINGW32__ */
@@ -2659,7 +2659,7 @@
if (close(p[0]) == -1 || close(p[1]) == -1)
fatal(_("close of pipe failed (%s)"), strerror(errno));
set_sigpipe_to_default();
- execl("/bin/sh", "sh", "-c", cmd, NULL);
+ execlp("sh", "sh", "-c", cmd, NULL);
_exit(errno == ENOENT ? 127 : 126);
}
#endif /* NOT __EMX__, NOT __MINGW32__ */
f6'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2021-02-12 | services: Add transmission-daemon service....* gnu/services/file-sharing.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* po/packages/POTFILES.in: Add it.
* tests/services/file-sharing.scm: New file.
* Makefile.am (SCM_TESTS): Add it.
* doc/guix.texi (File-Sharing Services): New section.
Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
| Simon South |
ef='/guix/commit/gnu/packages/matrix.scm?id=fb6de84a6b9ed38fc4fbf4fad89a0f8fe25111eb'>gnu: python-matrix-synapse-ldap3: Fix build....* gnu/packages/matrix.scm (python-matrix-synapse-ldap3)[arguments]: Delete
sanity check.
Marius Bakke |
2022-01-11 | gnu: pantalaimon: Disable sanity check....* gnu/packages/matrix.scm (pantalaimon)[arguments]: Disable sanity-check phase.
| Marius Bakke |
2021-12-13 | gnu: Simplify package inputs....This commit was obtained by running:
./pre-inst-env guix style
without any additional argument.
| Ludovic Courtès |
2021-10-18 | gnu: Add pantalaimon....* gnu/packages/matrix.scm (pantalaimon): New variable.
Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
| Sébastien Lerique |
2021-10-18 | gnu: Add python-matrix-nio....* gnu/packages/matrix.scm (python-matrix-nio): New variable.
Signed-off-by: Lars-Dominik Braun <lars@6xq.net>
| Sébastien Lerique |
2021-10-15 | gnu: synapse: Downgrade to 1.29.0....As discussed in [1] and [2], python-synapse 1.44.0 does not work with
our version of python-cryptography.
[1]: https://lists.gnu.org/archive/html/guix-patches/2021-10/msg00732.html
[2]: https://issues.guix.gnu.org/issue/48655
This reverts commit a6c30da4dc963e8a6282773fd1c2048d856a6cb4.
* gnu/packages/matrix.scm (synapse): Downgrade to 1.29.0.
Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
| Felix Gruber |
2021-10-12 | gnu: synapse: Update to 1.44.0....* gnu/packages/matrix.scm (synapse): Update to 1.44.0.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Felix Gruber |