As for libc's `system', change Awk to look for `sh' in $PATH. This patch is only meant to be used during bootstrapping, where we don't know in advance the absolute file name of `sh'. --- gawk-4.1.3/io.c 2015-05-19 15:37:20.000000000 +0200 +++ gawk-4.1.3/io.c 2015-06-09 18:39:36.918414881 +0200 @@ -2025,7 +2025,7 @@ set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", command, NULL); + execlp("sh", "sh", "-c", command, NULL); _exit(errno == ENOENT ? 127 : 126); case -1: @@ -2077,7 +2077,7 @@ signal(SIGPIPE, SIG_DFL); - execl("/bin/sh", "sh", "-c", command, NULL); + execlp("sh", "sh", "-c", command, NULL); _exit(errno == ENOENT ? 127 : 126); case -1: @@ -2422,7 +2422,7 @@ fatal(_("close of pipe failed (%s)"), strerror(errno)); /* stderr does NOT get dup'ed onto child's stdout */ set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", str, NULL); + execlp("sh", "sh", "-c", str, NULL); _exit(errno == ENOENT ? 127 : 126); } #endif /* NOT __EMX__, NOT __MINGW32__ */ @@ -2659,7 +2659,7 @@ if (close(p[0]) == -1 || close(p[1]) == -1) fatal(_("close of pipe failed (%s)"), strerror(errno)); set_sigpipe_to_default(); - execl("/bin/sh", "sh", "-c", cmd, NULL); + execlp("sh", "sh", "-c", cmd, NULL); _exit(errno == ENOENT ? 127 : 126); } #endif /* NOT __EMX__, NOT __MINGW32__ */ packages/ibus.scm'>
path: root/gnu/packages/ibus.scm
292'>root/gnu/packages/wine.scm
AgeCommit message (Expand)Author
AgeCommit message (Expand)Author
2023-02-05gnu: wine-minimal: Build more reproducibly.Kaelyn Takata
2023-02-05gnu: wine64: Share phases with parent wine package.Kaelyn Takata
2023-02-05gnu: wine-minimal: Make the parent of wine so phases can be shared.Kaelyn Takata
2023-02-05gnu: wine-staging: Update to 8.0.Kaelyn Takata
2023-02-05gnu: wine: Update to 8.0.Kaelyn Takata
2022-11-05gnu: wine: Update to 7.19.Liliana Marie Prikler
2022-05-21gnu: wine64: Use new package style.Liliana Marie Prikler
2022-05-21gnu: wine: Use new package style.Liliana Marie Prikler
2022-05-21gnu: wine-staging: Update to 7.8.Liliana Marie Prikler
2022-05-21gnu: wine: Update to 7.8.Liliana Marie Prikler
2022-01-16gnu: wine: Update to 7.0.Tobias Geerinckx-Rice
2021-12-24gnu: wine: Update to 6.20.Liliana Marie Prikler
2021-12-17gnu: Remove unneeded uses of custom GCC versions.Marius Bakke
2021-12-13gnu: Simplify package inputs.Ludovic Courtès
2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès
2021-08-30gnu: wine: Update to 6.16.Leo Prikler
2021-08-30gnu: wine: Update to 6.14.Leo Prikler
2021-07-24gnu: Use 'search-input-directory' and 'search-input-file' where appropriate.Ludovic Courtès