By default, master-failover will call "herd start ganeti-wconfd" with extra arguments such as --force-node. That does not work with the Shepherd, so the Guix service has a "force-start" action for this purpose. diff --git a/lib/bootstrap.py b/lib/bootstrap.py --- a/lib/bootstrap.py +++ b/lib/bootstrap.py @@ -1011,9 +1011,7 @@ def MasterFailover(no_voting=False): try: # Forcefully start WConfd so that we can access the configuration - result = utils.RunCmd([pathutils.DAEMON_UTIL, - "start", constants.WCONFD, "--force-node", - "--no-voting", "--yes-do-it"]) + result = utils.RunCmd(["herd", "force-start", constants.WCONFD]) if result.failed: raise errors.OpPrereqError("Could not start the configuration daemon," " command %s had exitcode %s and error %s" % d class='sub'>Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/bootloader
AgeCommit message (Expand)Author
2024-01-14bootloader: grub: Add support for loading an additional initrd....Tomas Volf
2023-12-22gnu: bootloader: Add orangepi-r1-plus-lts-rk3328 bootloader....Herman Rimm
2023-07-13bootloader: grub: Use rumpdisk-style root when booting with "noide"....Janneke Nieuwenhuizen
2023-06-14gnu: bootloader: Add u-boot-sifive-unmatched-bootloader....Efraim Flashner
2023-01-18gnu: Add u-boot-ts7970-q-2g-1000mhz-c-bootloader....Maxim Cournoyer
2022-12-28gnu: u-boot-am335x-boneblack: Revert to old name....Maxim Cournoyer
2022-12-20gnu: u-boot-am335x-evm-boneblack: Fix variable name....Maxim Cournoyer
2022-12-07bootloaders: grub: Fix comment....Maxim Cournoyer
2022-12-01gnu: bootloader: Rework chaining, add grub-efi-netboot-removable-bootloader....Stefan
2022-09-08gnu: bootloader: grub: Add support for chain-loader....tiantian
2022-08-30bootloader: Add device-tree-support? option....Reza Alizadeh Majd
2022-06-24image: Add support for 32bit UEFI....Denis 'GNUtoo' Carikli
2022-06-06bootloader: grub: Add removable grub-efi bootloader option....Karl Hallsby
2022-01-13bootloader: grub: Fix serial mode....Mathieu Othacehe
2021-12-01gnu: system: Add LUKS2 support for the root file system....Josselin Poiret
2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer
2021-05-29gnu: bootloader: Fix install-allwinner64-u-boot....Vagrant Cascadian