By default, master-failover will call "herd start ganeti-wconfd" with
extra arguments such as --force-node. That does not work with the
Shepherd, so the Guix service has a "force-start" action for this purpose.
diff --git a/lib/bootstrap.py b/lib/bootstrap.py
--- a/lib/bootstrap.py
+++ b/lib/bootstrap.py
@@ -1011,9 +1011,7 @@ def MasterFailover(no_voting=False):
try:
# Forcefully start WConfd so that we can access the configuration
- result = utils.RunCmd([pathutils.DAEMON_UTIL,
- "start", constants.WCONFD, "--force-node",
- "--no-voting", "--yes-do-it"])
+ result = utils.RunCmd(["herd", "force-start", constants.WCONFD])
if result.failed:
raise errors.OpPrereqError("Could not start the configuration daemon,"
" command %s had exitcode %s and error %s" %
d>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2016-07-22 | gnu: Update URLs for sourceforge.net....* gnu/packages/audio.scm: Update URLs pointing to sourceforge.net.
* gnu/packages/fonts.scm: Likewise.
* gnu/packages/gl.scm: Likewise.
* gnu/packages/gnome.scm: Likewise.
* gnu/packages/image.scm: Likewise.
* gnu/packages/lxde.scm: Likewise.
* gnu/packages/slim.scm: Likewise.
* gnu/packages/textutils.scm: Likewise.
| Leo Famulari |
2016-07-05 | gnu: menu-cache: Update to 1.0.1....* gnu/packages/lxde.scm (menu-cache): Update to 1.0.1.
| Efraim Flashner |
2016-07-05 | gnu: lxtask: Update to 0.1.7....* gnu/packages/lxde.scm (lxtask): Update to 0.1.7.
| Efraim Flashner |
2016-07-05 | gnu: lxrandr: Update to 0.3.1....* gnu/packages/lxde.scm (lxrandr): Update to 0.3.1.
| Efraim Flashner |
2016-07-05 | gnu: lxappearance: Update to 0.6.2....* gnu/packages/lxde.scm (lxappearance): Update to 0.6.2.
| Efraim Flashner |
2016-04-13 | gnu: pcmanfm, libfm: Update to 1.2.4....* gnu/packages/lxde.scm (pcmanfm): Update to 1.2.4.
* gnu/packages/lxde.scm (libfm): Update to 1.2.4.
Signed-off-by: Leo Famulari <leo@famulari.name>
| Raymond Nicholson |