Relax version constraints to work with Stackage LTS 19.
Taken from upstream:
https://github.com/ganeti/ganeti/commit/4f8d61ea0101721eae1c6f43be8430d819e5e611
diff --git a/cabal/ganeti.template.cabal b/cabal/ganeti.template.cabal
index bb4ff8053..98491dd9f 100644
--- a/cabal/ganeti.template.cabal
+++ b/cabal/ganeti.template.cabal
@@ -63,14 +63,14 @@ library
, unix >= 2.5.1.0
, utf8-string >= 0.3.7
- , attoparsec >= 0.10.1.1 && < 0.14
- , base64-bytestring >= 1.0.0.1 && < 1.2
+ , attoparsec >= 0.10.1.1 && < 0.15
+ , base64-bytestring >= 1.0.0.1 && < 1.3
, case-insensitive >= 0.4.0.1 && < 1.3
, curl >= 1.3.7 && < 1.4
, hinotify >= 0.3.2 && < 0.5
, hslogger >= 1.1.4 && < 1.4
, json >= 0.5 && < 1.0
- , lens >= 3.10 && < 5.0
+ , lens >= 3.10 && < 6.0
, lifted-base >= 0.2.0.3 && < 0.3
, monad-control >= 0.3.1.3 && < 1.1
, parallel >= 3.2.0.2 && < 3.3
'/guix/commit/tests/records.scm?id=ab5011a7abb552a19fdd46af1579292642accb89'>commitdiff
|
Age | Commit message (Expand) | Author |
2023-06-04 | tests: records: Add test for ellipsis in body....* tests/records.scm ("match-record, ellipsis in body"): New test.
| Josselin Poiret |
2023-06-04 | records: Add MATCH-RECORD-LAMBDA....* guix/records.scm (match-record-lambda): New syntax.
* tests/records.scm ("match-record-lambda"): New test.
Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
| (unmatched-parenthesis ew syntax |
2023-06-04 | records: match-record: Support thunked and delayed fields....* guix/records.scm (match-record): Unwrap matched thunked and delayed fields.
* tests/records.scm ("match-record, thunked field",
"match-record, delayed field"): New tests.
Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
| (unmatched-parenthesis d |
2022-12-27 | records: match-record supports specifying a different variable name....An example:
(match-record obj <my-type>
(field1 (field2 custom-var-name) field3)
...)
* guix/records.scm (match-record-inner): Add support for the new syntax.
* tests/records.scm ("match-record, simple"): Add a simple test case for the
new syntax.
Signed-off-by: Ludovic Courtès <ludo@gnu.org>
| Attila Lendvai |
2022-12-02 | records: 'match-record' checks fields at macro-expansion time....This allows 'match-record' to be more efficient (field offsets are
computed at compilation time) and to report unknown fields at
macro-expansion time.
* guix/records.scm (map-fields): New macro.
(define-record-type*)[rtd-identifier]: New procedure.
Define TYPE as a macro and use a separate identifier for the RTD.
(lookup-field, match-record-inner): New macros.
(match-record): Rewrite in terms of 'match-error-inner'.
* tests/records.scm ("match-record, simple")
("match-record, unknown field"): New tests.
* gnu/services/cuirass.scm (cuirass-shepherd-service): Rename 'log-file'
local variable to 'main-log-file'.
* gnu/services/getmail.scm (serialize-getmail-configuration-file): Move
after <getmail-configuration-file> definition.
| Ludovic Courtès |
2022-07-01 | tests: Add sanitizer test....* tests/records.scm ("define-record-type* & sanitize without default
value"): New test.
| Ludovic Courtès |