Do not override PYTHONPATH when calling Python code from the Haskell daemons. This is necessary because the Python library dependencies are only available through PYTHONPATH. diff --git a/src/Ganeti/Query/Exec.hs b/src/Ganeti/Query/Exec.hs --- a/src/Ganeti/Query/Exec.hs +++ b/src/Ganeti/Query/Exec.hs @@ -99,12 +99,10 @@ spawnJobProcess jid = withErrorLogAt CRITICAL (show jid) $ do use_debug <- isDebugMode env_ <- (M.toList . M.insert "GNT_DEBUG" (if use_debug then "1" else "0") - . M.insert "PYTHONPATH" AC.pythondir . M.fromList) `liftM` getEnvironment execPy <- P.jqueueExecutorPy logDebug $ "Executing " ++ AC.pythonPath ++ " " ++ execPy - ++ " with PYTHONPATH=" ++ AC.pythondir (master, child) <- pipeClient connectConfig let (rh, wh) = clientToHandle child pe='submit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/speech.scm
AgeCommit message (Expand)Author
2019-11-13gnu: sonic: Don't use unstable tarball....* gnu/packages/speech.scm (sonic)[source]: Download using git-fetch. Efraim Flashner
2019-10-09gnu: espeak: Build with the C++ 98 standard....Fixes <https://bugs.gnu.org/37672>. Reported by Bradley Haggerty <bradigger@gmail.com>. * gnu/packages/speech.scm (espeak)[arguments]: Add CXXFLAGS to #:make-flags. Marius Bakke
2019-09-18gnu: festival: Fix scripts....* gnu/packages/speech.scm (festival)[arguments]: Fix broken shebangs in scripts. Ricardo Wurmus
2019-09-18gnu: festival: Include default voice....* gnu/packages/speech.scm (festival)[arguments]: Install default voice. [native-inputs]: Add default voice. Ricardo Wurmus
2019-09-17gnu: festival: Install missing info files....Reported by reepca on the #guix IRC channel. This is a follow-up to commit 34583ec6e3995f5dd1ebf549265f0d64bbf23ab7. * gnu/packages/speech.scm (festival)[arguments]: Install missing info files. Ricardo Wurmus
2019-09-17gnu: Add festival....* gnu/packages/speech.scm (festival): New variable. Ricardo Wurmus
2019-05-13gnu: speech-dispatcher: Update to 0.9.1....* gnu/packages/speech.scm (speech-dispatcher): Update to 0.9.1. [arguments]: Add "--with-ibmtts=no" to #:configure-flags. [license]: Remove GPL2. Marius Bakke
2019-02-28gnu: speech-dispatcher: Build against eSpeak NG....* gnu/packages/speech.scm (speech-dispatcher)[inputs]: Change from ESPEAK to ESPEAK-NG. Marius Bakke
2019-02-28gnu: Add eSpeak NG....* gnu/packages/speech.scm (espeak-ng): New public variable. Marius Bakke
2019-02-28gnu: Move espeak to speech.scm....* gnu/packages/audio.scm (espeak): Move from here ... * gnu/packages/speech.scm (espeak): ... to here. Marius Bakke
2019-02-28gnu: speech-dispatcher: Update to 0.9.0....* gnu/packages/speech.scm (speech-dispatcher): Update to 0.9.0. [source](uri): Change to new upstream URI. [arguments]: Add --with-kali and --with-baratinoo to #:configure-flags. Marius Bakke
2019-02-28gnu: speech-dispatcher: Don't build static libraries....* gnu/packages/speech.scm (speech-dispatcher)[arguments]: New field. Marius Bakke