This patch allows the build process to use the provided dependencies instead
of adding their source as CMake sub-directories (in which case "make install"
would install googletest's and googlebenchmark's libraries and headers).
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bcae6b5..ff6710d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -21,7 +21,7 @@ IF(FXDIV_BUILD_TESTS)
ENDIF()
# ---[ Download deps
-IF(FXDIV_BUILD_TESTS AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
+IF(FALSE)
MESSAGE(STATUS "Downloading Google Test to ${CMAKE_BINARY_DIR}/googletest-source (define GOOGLETEST_SOURCE_DIR to avoid it)")
CONFIGURE_FILE(cmake/DownloadGoogleTest.cmake "${CMAKE_BINARY_DIR}/googletest-download/CMakeLists.txt")
EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
@@ -31,7 +31,7 @@ IF(FXDIV_BUILD_TESTS AND NOT DEFINED GOOGLETEST_SOURCE_DIR)
SET(GOOGLETEST_SOURCE_DIR "${CMAKE_BINARY_DIR}/googletest-source" CACHE STRING "Google Test source directory")
ENDIF()
-IF(FXDIV_BUILD_BENCHMARKS AND NOT DEFINED GOOGLEBENCHMARK_SOURCE_DIR)
+IF(FALSE)
MESSAGE(STATUS "Downloading Google Benchmark to ${CMAKE_BINARY_DIR}/googlebenchmark-source (define GOOGLEBENCHMARK_SOURCE_DIR to avoid it)")
CONFIGURE_FILE(cmake/DownloadGoogleBenchmark.cmake "${CMAKE_BINARY_DIR}/googlebenchmark-download/CMakeLists.txt")
EXECUTE_PROCESS(COMMAND "${CMAKE_COMMAND}" -G "${CMAKE_GENERATOR}" .
@@ -54,7 +54,7 @@ INSTALL(FILES include/fxdiv.h DESTINATION ${CMAKE_INSTALL_INCLUDEDIR})
IF(FXDIV_BUILD_TESTS)
# ---[ Build google test
- IF(NOT TARGET gtest)
+ IF(FALSE)
SET(gtest_force_shared_crt ON CACHE BOOL "" FORCE)
ADD_SUBDIRECTORY(
"${GOOGLETEST_SOURCE_DIR}"
@@ -78,7 +78,7 @@ ENDIF()
IF(FXDIV_BUILD_BENCHMARKS)
# ---[ Build google benchmark
- IF(NOT TARGET benchmark)
+ IF(FALSE)
SET(BENCHMARK_ENABLE_TESTING OFF CACHE BOOL "" FORCE)
ADD_SUBDIRECTORY(
"${GOOGLEBENCHMARK_SOURCE_DIR}"
q' value=''/>
guix-install.sh: Prompt for configuring substitutes discovery....Also ensure prompt_yes_no always print the message with a trailing space,
which is more pleasing to the eye.
* etc/guix-daemon.conf.in <--discover=no>: New guix-daemon option.
* etc/guix-daemon.service.in: Likewise.
* etc/init.d/guix-daemon.in: Likewise.
* etc/openrc/guix-daemon.in: Likewise.
* etc/guix-install.sh (configure_substitute_discovery): New procedure.
(sys_enable_guix_daemon): Ask the user whether automatic substitute discovery
should be enabled. Set the '--discover' argument accordingly.
(prompt_yes_no): Add a trailing space to the message.
(sys_authorize_build_farms): Remove trailing space from the message argument.
* NEWS (Distribution): Add news.
Maxim Cournoyer
2019-06-05
etc: guix-daemon.service.in: Fix GUIX_LOCPATH quoting....Fixes <https://bugs.gnu.org/36074>.
* etc/guix-daemon.service.in: Move the GUIX_LOCPATH environment variable name
inside the quotes.
Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Jack Hill
2019-05-13
Set 'LC_ALL=en_US.utf8' in systemd '.service' files....Fixes <https://bugs.gnu.org/35671>.
* etc/guix-daemon.service.in (Environment): Quote the 'GUIX_LOCPATH'
value; add 'LC_ALL'.
* etc/guix-publish.service.in (Environment): Likewise.