Upstream-status: https://sourceforge.net/p/freesolid/patches/1/
Resolve Autoconf warnings.
diff --git a/Makefile.am b/Makefile.am
index 4914f44..77b157a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,5 @@
+ACLOCAL_AMFLAGS = -I m4
SUBDIRS = libmoto libbroad libsolid sample doc
EXTRA_DIST = include
-bin_SCRIPTS = freesolid-config
\ No newline at end of file
+bin_SCRIPTS = freesolid-config
diff --git a/configure.in b/configure.in
index 7d61ba5..41a761c 100644
--- a/configure.in
+++ b/configure.in
@@ -1,5 +1,6 @@
dnl Process this file with autoconf to produce a configure script.
AC_INIT(sample/sample.cpp)
+AC_CONFIG_MACRO_DIR([m4])
AC_CANONICAL_SYSTEM
PACKAGE=FreeSOLID
@@ -22,17 +23,14 @@ AC_PROG_CXX
AC_PROG_CC
AC_PROG_CPP
AC_PROG_INSTALL
-AC_PROG_RANLIB
AC_PROG_LIBTOOL
CPPFLAGS="$CPPFLAGS -I../include -I./include -I. -I../libbroad -I../libmoto"
AC_SUBST(CPPFLAGS)
dnl Checks for libraries.
-dnl Replace `main' with a function in -lm:
-AC_CHECK_LIB(m, main)
-dnl Replace `main' with a function in -lqhull:
-AC_CHECK_LIB(qhull, main, s_have_qhull=yes)
+AC_CHECK_LIB(m, ceil)
+AC_CHECK_LIB(qhull, qh_initbuild, s_have_qhull=yes)
if test "X${s_have_qhull}" = Xyes; then
QHULL_LIBS="-lqhull"
diff --git a/libsolid/Makefile.am b/libsolid/Makefile.am
index cc295c7..f722be3 100644
--- a/libsolid/Makefile.am
+++ b/libsolid/Makefile.am
@@ -23,7 +23,7 @@ libFreeSOLID_la_SOURCES = \
libFreeSOLID_la_LDFLAGS = -no-undefined -version-info @FREESOLID_CURRENT@:@FREESOLID_REVISION@:@FREESOLID_AGE@ -release @VERSION@
-CPPFLAGS = @CPPFLAGS@
+AM_CPPFLAGS = @CPPFLAGS@
LIBS = @QHULL_LIBS@ -lm
pkginclude_HEADERS = \
diff --git a/sample/Makefile.am b/sample/Makefile.am
index 5559fb0..eaa705f 100644
--- a/sample/Makefile.am
+++ b/sample/Makefile.am
@@ -4,7 +4,7 @@ sample_SOURCES = sample.cpp
x_wing_SOURCES = x_wing.cpp
teapot_SOURCES = teapot.cpp
-CPPFLAGS = @CPPFLAGS@
+AM_CPPFLAGS = @CPPFLAGS@
LDADD = ../libsolid/libFreeSOLID.la
itter
Age | Commit message (Expand) | Author |
2021-08-29 | Migrate to the new 'targets' field of bootloader-configuration....The old 'target' field is deprecated; adjust the sources to use the new
'targets' one instead.
* doc/guix-cookbook.texi<target>: Replace by 'targets'.
* gnu/bootloader/grub.scm: Likewise.
* gnu/installer/parted.scm: Likewise.
* gnu/machine/digital-ocean.scm: Likewise.
* gnu/system/examples/asus-c201.tmpl: Likewise
* gnu/system/examples/bare-bones.tmpl: Likewise
* gnu/system/examples/bare-hurd.tmpl: Likewise
* gnu/system/examples/beaglebone-black.tmpl: Likewise
* gnu/system/examples/desktop.tmpl: Likewise
* gnu/system/examples/docker-image.tmpl: Likewise
* gnu/system/examples/lightweight-desktop.tmpl: Likewise
* gnu/system/examples/vm-image.tmpl: Likewise
* gnu/system/examples/yggdrasil.tmpl: Likewise
* gnu/system/hurd.scm: Likewise
* gnu/system/images/hurd.scm: Likewise
* gnu/system/images/novena.scm: Likewise
* gnu/system/images/pine64.scm: Likewise
* gnu/system/images/pinebook-pro.scm: Likewise
* gnu/system/images/rock64.scm: Likewise
* gnu/system/install.scm: Likewise
* gnu/system/vm.scm: Likewise
* gnu/tests.scm: Likewise
* gnu/tests/ganeti.scm: Likewise
* gnu/tests/install.scm: Likewise
* gnu/tests/nfs.scm: Likewise
* gnu/tests/telephony.scm: Likewise
* tests/boot-parameters.scm: Likewise
* tests/system.scm: Likewise
| Maxim Cournoyer |
2020-10-13 | installer: Add Emacs EXWM desktop environment....Suggested by zenny via IRC.
* gnu/installer/services.scm (%system-services): Add emacs, emacs-exwm,
emacs-desktop-environment.
* etc/release-manifest.scm (%system-packages): Likewise.
* gnu/system/examples/lightweight-desktop.tmpl: Likewise.
* gnu/tests/install.scm (installation-target-desktop-os-for-gui-tests)
[packages]: Likewise
* gnu/installer/newt/services.scm (run-desktop-environments-cbt-page): Make
one entry taller.
| Jan (janneke) Nieuwenhuizen |
2020-08-28 | system: Remove extra line from 'lightweight-desktop.tmpl'....This is a followup to c7af96871737ffa0e2be879e200573bc60603c8c.
* gnu/system/examples/lightweight-desktop.tmpl: Remove extra
'use-package-modules' line.
| Ludovic Courtès |
2020-04-02 | system: Add xterm to lightweight-desktop example....That makes ratpoison more usable, for instance.
* gnu/system/examples/lightweight-desktop.tmpl (packages): Add XTERM.
| Ludovic Courtès |