Use the new TIFFFieldSetGetSize API from libtiff 4.4 instead of the
private and removed _TIFFDataSize declared in the unbundling patch.
Patch taken from Fedora:
https://src.fedoraproject.org/rpms/freeimage/blob/rawhide/f/freeimage-libtiff44.patch
diff -rupN --no-dereference freeimage-svn-r1889-FreeImage-trunk/Source/Metadata/XTIFF.cpp freeimage-svn-r1889-FreeImage-trunk-new/Source/Metadata/XTIFF.cpp
--- freeimage-svn-r1889-FreeImage-trunk/Source/Metadata/XTIFF.cpp 2022-06-23 11:56:32.561043826 +0200
+++ freeimage-svn-r1889-FreeImage-trunk-new/Source/Metadata/XTIFF.cpp 2022-06-23 11:56:32.764043827 +0200
@@ -747,7 +747,7 @@ tiff_write_exif_tags(TIFF *tif, TagLib::
continue;
}
// type of storage may differ (e.g. rationnal array vs float array type)
- if((unsigned)_TIFFDataSize(tif_tag_type) != FreeImage_TagDataWidth(tag_type)) {
+ if((unsigned)TIFFFieldSetGetSize(fld) != FreeImage_TagDataWidth(tag_type)) {
// skip tag or _TIFFmemcpy will fail
continue;
}
class='tabs'>
aboutsummaryrefslogtreecommitdiff |
|
Age | Commit message (Expand) | Author |
2022-06-24 | image: Add support for 32bit UEFI.... | Denis 'GNUtoo' Carikli |
2021-11-12 | build: bootloader: Add GPT support.... | Mathieu Othacehe |
1-fix-build-witch-gcc7.5.patch: New file.
* gnu/local.mk (dist_patch_DATA): Adjust accordingly.
* gnu/packages/inkscape.scm (inkscape-1.0) Rename to inkscape-1.1.
* gnu/packages/inkscape.scm (inkscape-1.1) Update to version 1.1.
Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
|
* gnu/packages/inkscape.scm (inkscape-1.0): Update to 1.0.2.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
|