The compression utility dictzip writes the compressed file's mtime in a header
of the compressed file. No command-line switch is documented to control or
suppress this behavior. This makes the build of packages relying on
freedict-tools such as freedict-dictionaries non-deterministic.
This patch sets the mtime of the .dict file to be compressed by dictzip to the
start of the epoch on the Greenwich meridian, restoring build determinism.
diff --git a/mk/dicts.mk b/mk/dicts.mk
index 08e8923..e671cf3 100644
--- a/mk/dicts.mk
+++ b/mk/dicts.mk
@@ -265,7 +265,8 @@ $(BUILD_DICTD)/%.dict $(BUILD_DICTD)/%.index: $(BUILD_DICTD)/%.c5 query-dictd
dictfmt --without-time -t --headword-separator %%% $(DICTFMTFLAGS) $* < $(notdir $<)
$(BUILD_DICTD)/%.dict.dz: $(BUILD_DICTD)/%.dict
- dictzip -k $<
+ touch -m -d "$$(date -u -R -d @0)" $< && \
+ dictzip -k $<
# prevent make from removing our precious file
.PRECIOUS: $(BUILD_DICTD)/$(dictname).dict
table class='tabs'>
aboutsummaryrefslogtreecommitdiff |
|
Age | Commit message (Expand) | Author |
2021-06-13 | bootstrap: Simplify search for translation languages....Extend the sed script to also behave like "basename",
saving the addtional call of "xargs basename".
* bootstrap (langs): Extend sed scripts, remove running xargs.
| Hartmut Goebel |
2020-02-17 | bootstrap: Fix typo....* bootstrap: Substitute ‘guix-cookbook’ for copy/pasted ‘guix-manual’.
Reported-by: jetomit on #guix
| Tobias Geerinckx-Rice |
2019-09-18 | doc: Add Guix Cookbook....* .gitignore: Update ignore list.
* Makefile.am (assert-no-store-file-names): Exclude the cookbook.
* bootstrap: Generate po files for cookbook translations.
* doc/guix-cookbook.texi: New file.
* doc/local.mk (info_TEXINFOS): Add it; add a rule to build cookbook
translations.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): New variable.
(EXTRA_DIST): Add cookbook pot file and po files.
(doc-po-update-cookbook-%): New target.
(doc-pot-update): Also update cookbook pot file.
(doc-po-update): Also update cookbook po files.
| Ricardo Wurmus |
2019-04-26 | bootstrap: Break automake dependency on generated files....* bootstrap: Generate stub files for the manual translations whose
generated files are not included in the VCS.
* doc/contributing.de.texi: Remove file.
* doc/contributing.es.texi: Remove file.
* doc/contributing.fr.texi: Remove file.
* doc/contributing.zh_CN.texi: Remove file.
* doc/guix.de.texi: Remove file.
* doc/guix.es.texi: Remove file.
* doc/guix.fr.texi: Remove file.
* doc/guix.zh_CN.texi: Remove file.
* .gitignore: Add them.
Signed-off-by: Julien Lepiller <julien@lepiller.eu>
| Miguel Ángel Arruga Vivas |