Prevent implicit conversion of float to double to avoid precision error on i686. https://github.com/Maratyszcza/FP16/issues/20 Taken from Debian: https://salsa.debian.org/deeplearning-team/fp16/-/blob/master/debian/patches/ftbfs-i386.patch Index: fp16/include/fp16/fp16.h =================================================================== --- fp16.orig/include/fp16/fp16.h +++ fp16/include/fp16/fp16.h @@ -228,7 +228,8 @@ static inline uint16_t fp16_ieee_from_fp const float scale_to_inf = fp32_from_bits(UINT32_C(0x77800000)); const float scale_to_zero = fp32_from_bits(UINT32_C(0x08800000)); #endif - float base = (fabsf(f) * scale_to_inf) * scale_to_zero; + const volatile float base_inf = fabsf(f) * scale_to_inf; + float base = base_inf * scale_to_zero; const uint32_t w = fp32_to_bits(f); const uint32_t shl1_w = w + w; Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/icu4c.scm
AgeCommit message (Expand)Author
2016-10-23gnu: icu4c: On MIPS, pass --with-data-packaging=archive to configure....Mark H Weaver
2016-04-14gnu: packages: Use 'search-patches' everywhere....Alex Kost
2016-02-21gnu: icu4c: Fetch from sourceforge....Andy Wingo
2015-09-19gnu: icu4c: Add fixes for CVE-2014-6585 and CVE-2015-1270....Mark H Weaver
2015-08-03gnu: icu4c: Add fix for CVE-2015-4760....Mark H Weaver
2015-05-12gnu: icu4c: Update to 55.1....Mark H Weaver
2015-01-06gnu: icu4c: Avoid use of 'patchelf'; fix build on ARM systems....Mark H Weaver
2014-11-20gnu: icu4c: Update to 54.1....Andreas Enge
2014-10-26gnu: Some cleanup based on lint checkers....Eric Bavier
2014-10-13gnu: icu4c: Reinstate RUNPATH on shared libraries....Ludovic Courtès
2014-10-10gnu: icu4c: Correct error in the binaries' runpath...John Darrington
2014-06-16gnu: icu4c: Upgrade to 53.1....Ludovic Courtès
2014-06-16gnu: icu4c: Fix failing test....Ludovic Courtès
2014-03-31gnu: Remove unused lambda arguments and prefer separate phases over...Eric Bavier
2014-02-17gnu: icu4c: Upgrade to 52.1....Mark H Weaver
2013-12-15gnu: Move libelf and patchelf to (gnu packages elf)....Ludovic Courtès
2013-10-06gnu: icu4c: Patch RUNPATH of libraries....Andreas Enge