Propagate source font modification time to svg during conversion. Similar to what upstream commit 95a470e941d9a20fbdaca51334e8b6b9d93cfae4 did for TTF files. Submitted upstream at http://github.com/fontforge/fontforge/pull/2696 --- a/fontforge/svg.c +++ b/fontforge/svg.c @@ -27,7 +27,6 @@ #include "fontforgevw.h" #include #include -#include #include #include #include @@ -62,7 +61,6 @@ static int svg_outfontheader(FILE *file, SplineFont *sf,int layer) { BlueData bd; char *hash, *hasv, ch; int minu, maxu, i; - time_t now; const char *author = GetAuthor(); memset(&info,0,sizeof(info)); @@ -78,9 +76,8 @@ static int svg_outfontheader(FILE *file, SplineFont *sf,int layer) { fprintf( file, "\n-->\n" ); } fprintf( file, "\n" ); - time(&now); fprintf( file, "\nCreated by FontForge %d at %s", - FONTFORGE_VERSIONDATE_RAW, ctime(&now) ); + FONTFORGE_VERSIONDATE_RAW, ctime((time_t*)&sf->modificationtime) ); if ( author!=NULL ) fprintf(file," By %s\n", author); else ne?id=02d6e27e15d66ef557b90479a7920aabd15e42bf'>treecommitdiff
AgeCommit message (Expand)Author
2019-12-08machine: Remove unnecessary record self-referencing bindings....Ludovic Courtès
2019-12-07machine: ssh: Deprecate missing 'host-key' field....Ludovic Courtès
2019-12-04machine: ssh: <machine-ssh-configuration> can include the host key....Ludovic Courtès
2019-10-22machine: digital-ocean: Rename 'enable-ipv6' to 'enable-ipv6?'....Ludovic Courtès
2019-10-22machine: Implement 'digital-ocean-environment-type'....Jakob L. Kreuze
2019-08-17machine: ssh: Fix sanity checks....宋文武
2019-08-16machine: Use 'become-command'....Jakob L. Kreuze
2019-08-15machine: Automatically authorize the coordinator's signing key....Jakob L. Kreuze
2019-08-15machine: Implement 'roll-back-machine'....Jakob L. Kreuze
2019-08-15machine: Allow non-root users to deploy....Jakob L. Kreuze
2019-08-14remote: Build derivations appropriate for the remote's...Jakob L. Kreuze
2019-08-07machine: Add 'build-locally?' field for managed hosts....Jakob L. Kreuze
2019-08-06machine: Implement safety checks....Jakob L. Kreuze
2019-08-06machine: Rename 'system' field....Jakob L. Kreuze
2019-07-26guix system: Add 'reconfigure' module....Jakob L. Kreuze
2019-07-18machine: Fix typo....Tobias Geerinckx-Rice
2019-07-06gnu: Add machine type for deployment specifications....Jakob L. Kreuze