Fixes undefined reference to `Fl_XFont_On_Demand::value()'. From . Index: src/fl_font.cxx =================================================================== --- fltk-1.3.3/src/fl_font.cxx (revision 10503) +++ fltk-1.3.3/src/fl_font.cxx (revision 10504) @@ -55,6 +55,12 @@ # include "fl_font_x.cxx" #endif // WIN32 +#if ! (defined(WIN32) || defined(__APPLE__)) +XFontStruct *fl_X_core_font() +{ + return fl_xfont.value(); +} +#endif double fl_width(const char* c) { if (c) return fl_width(c, (int) strlen(c)); Index: src/gl_draw.cxx =================================================================== --- fltk-1.3.3/src/gl_draw.cxx (revision 10503) +++ fltk-1.3.3/src/gl_draw.cxx (revision 10504) @@ -81,7 +81,7 @@ * then sorting through them at draw time (for normal X rendering) to find which one can * render the current glyph... But for now, just use the first font in the list for GL... */ - XFontStruct *font = fl_xfont; + XFontStruct *font = fl_X_core_font(); int base = font->min_char_or_byte2; int count = font->max_char_or_byte2-base+1; fl_fontsize->listbase = glGenLists(256); Index: FL/x.H =================================================================== --- fltk-1.3.3/FL/x.H (revision 10503) +++ fltk-1.3.3/FL/x.H (revision 10504) @@ -132,6 +132,7 @@ XFontStruct *ptr; }; extern FL_EXPORT Fl_XFont_On_Demand fl_xfont; +extern FL_EXPORT XFontStruct* fl_X_core_font(); // this object contains all X-specific stuff about a window: // Warning: this object is highly subject to change! me='id' value='a2cee77c50079df09e6d9758260ba05e16e8731c'/>
path: root/gnu/bootloader.scm
AgeCommit message (Expand)Author
2022-12-01gnu: bootloader: Rework chaining, add grub-efi-netboot-removable-bootloader....Stefan
2022-09-08gnu: bootloader: Report error in menu-entry....tiantian
2022-09-08gnu: bootloader: Extend `<menu-entry>' for chain-loader....tiantian
2022-08-30bootloader: Wrap lines....Mathieu Othacehe
2022-08-30bootloader: Add device-tree-support? option....Reza Alizadeh Majd
2022-08-28bootloader: Convert device in menu-entry to proper sexp....Josselin Poiret
2022-08-21bootloader: Remove expired export....Tobias Geerinckx-Rice
2021-11-17gnu: system: Improve location of some configuration warnings....Josselin Poiret
2021-08-30bootloader: Report location of the deprecated 'target' field....Ludovic Courtès
2021-08-29gnu: bootloader: Support multiple targets....Maxim Cournoyer