Do not try to create $localstatedir (aka. /var) since we don't have
write access.
--- findutils-4.4.2/locate/Makefile.in 2015-06-04 12:40:52.690935795 +0200
+++ findutils-4.4.2/locate/Makefile.in 2015-06-04 12:41:32.087286685 +0200
@@ -1212,7 +1212,7 @@ updatedb: updatedb.sh Makefile
chmod +x $@
install-data-hook:
- $(top_srcdir)/build-aux/mkinstalldirs $(DESTDIR)$(localstatedir)
+ true
dblocation.texi: Makefile
echo '@set LOCATE_DB $(LOCATE_DB)' > $@
class='main'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-07-07 | guix-install.sh: Prompt for configuring substitutes discovery....Also ensure prompt_yes_no always print the message with a trailing space,
which is more pleasing to the eye.
* etc/guix-daemon.conf.in <--discover=no>: New guix-daemon option.
* etc/guix-daemon.service.in: Likewise.
* etc/init.d/guix-daemon.in: Likewise.
* etc/openrc/guix-daemon.in: Likewise.
* etc/guix-install.sh (configure_substitute_discovery): New procedure.
(sys_enable_guix_daemon): Ask the user whether automatic substitute discovery
should be enabled. Set the '--discover' argument accordingly.
(prompt_yes_no): Add a trailing space to the message.
(sys_authorize_build_farms): Remove trailing space from the message argument.
* NEWS (Distribution): Add news.
| Maxim Cournoyer |
2020-09-17 | guix-install.sh: Support OpenRC....* etc/guix-install.sh (chk_init_sys): Detect OpenRC.
(sys_enable_guix_daemon): Install & enable the Guix daemon on such
systems.
* etc/openrc/guix-daemon.in: New file.
* nix/local.mk: Add a rule for it.
(openrcservicedir, nodist_openrcservice_DATA): New variables.
(CLEANFILES, EXTRA_DIST): Add them.
* .gitignore: Ignore etc/openrc/guix-daemon.
Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
| Morgan Smith |