From 0871db30bd73d112a434f54572d34cca28de61c5 Mon Sep 17 00:00:00 2001 From: fis Date: Sat, 26 May 2018 22:58:37 +0800 Subject: [PATCH 2/2] * CMakeLists.txt: Fix flags for gcc. --- CMakeLists.txt | 18 ++---------------- 1 file changed, 2 insertions(+), 16 deletions(-) diff --git a/CMakeLists.txt b/CMakeLists.txt index eba147b..d60dcef 100644 --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -6,20 +6,6 @@ add_executable(unit src/fifo_map.hpp test/unit.cpp) target_include_directories(unit PRIVATE "test" "src") -if(MSVC) - set(CMAKE_CXX_FLAGS - "/EHsc" - ) +set(CMAKE_CXX_FLAGS "-std=c++11 -fpermissive") - STRING(REPLACE "/O2" "/Od" CMAKE_CXX_FLAGS_RELEASE ${CMAKE_CXX_FLAGS_RELEASE}) - - add_definitions(-D_SCL_SECURE_NO_WARNINGS) -else(MSVC) - set(CMAKE_CXX_FLAGS - "-std=c++11 -stdlib=libc++" - ) -endif(MSVC) - -include_directories( - src test -) +include_directories(src test) -- 2.14.3 e>
aboutsummaryrefslogtreecommitdiff
path: root/gnu/machine
AgeCommit message (Expand)Author
2021-02-25machine: ssh: Use 'formatted-message'....Ludovic Courtès
2021-01-04machine: ssh: Do not import the host (guix config), really....Ludovic Courtès
2020-12-21system: Allow separated /boot and encrypted root....Miguel Ángel Arruga Vivas
2020-11-09machine: ssh: Do not import the host (guix config)....Ludovic Courtès
2020-11-01system: Add store-directory-prefix to boot-parameters....Miguel Ángel Arruga Vivas
2020-10-18system: Provide locale information to the bootloader....Miguel Ángel Arruga Vivas
2020-09-07linux-boot: Handle nfs-root device strings....Stefan
2020-08-25Remove "guile-zlib" extension when unused....Mathieu Othacehe
2020-08-25linux-libre: Support module compression....Mathieu Othacehe
2020-07-27machine: ssh: Check for potential system downgrades....Ludovic Courtès
2020-07-25Use 'formatted-message' instead of '&message' where appropriate....Ludovic Courtès
2020-06-28Add more missing (ice-9 format) imports....Marius Bakke
2020-06-18machine: ssh: Fix guix deploy hang when using non-DCE UUIDs....Maxim Cournoyer
2020-03-23machine: ssh: Better report missing initrd modules....Ludovic Courtès
2020-03-23machine: ssh: Make sanity checks in a single round trip....Ludovic Courtès