Fix build failure when using Swig 4. Taken from upstream: https://github.com/fifengine/fifengine/commit/d14f232f4cd9a00b05d6872957070e8c020f515d diff --git a/CMakeLists.txt b/CMakeLists.txt --- a/CMakeLists.txt +++ b/CMakeLists.txt @@ -893,7 +893,7 @@ if(build-python) find_package(PythonLibs ${PYTHON_VERSION_STRING} EXACT) include_directories(${PYTHON_INCLUDE_PATH}) - set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -nosafecstrings -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -nobuildnone -keyword -w511 -w473 -w404 -w314) + set(CMAKE_SWIG_FLAGS -modern -fastdispatch -dirvtable -noproxydel -fastproxy -fastinit -fastunpack -fastquery -modernargs -keyword -w511 -w473 -w404 -w314) set_source_files_properties("${PROJECT_BINARY_DIR}/fife.i" PROPERTIES CPLUSPLUS ON) set(FIFE_SOURCES ${FIFE_CORE_SRC}) pe='submit' value='switch'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/openpgp.scm
AgeCommit message (Expand)Author
2020-09-29openpgp: Fix argument order of 'fxbit-set?'....Lars-Dominik Braun
2020-05-04openpgp: Add 'string->openpgp-packet'....Ludovic Courtès
2020-05-04openpgp: 'lookup-key-by-{id,fingerprint}' return the key first....Ludovic Courtès
2020-05-04openpgp: 'verify-openpgp-signature' looks up by fingerprint when possible....Ludovic Courtès
2020-05-04openpgp: Add 'lookup-key-by-fingerprint'....Ludovic Courtès
2020-05-04openpgp: Store the issuer key id and fingerprint in <openpgp-signature>....Ludovic Courtès
2020-05-04openpgp: Decode the issuer-fingerprint signature subpacket....Ludovic Courtès
2020-05-04Add (guix openpgp)....Ludovic Courtès