The `BOOST_LITTLE_ENDIAN` and `BOOST_BIG_ENDIAN` macros, along with the "boost/detail/endian.hpp" header, were deprecated in boost 1.69.0 and finally removed in boost 1.73.0. They are superseded by the BOOST_ENDIAN_LITTLE_BYTE and BOOST_ENDIAN_BIG_BYTE macros and "boost/predef/other/endian.h" header. Deprecated: https://github.com/boostorg/predef/commit/32d4581c1689370444f2e565cfbb8421d5071807 Removed: https://github.com/boostorg/predef/commit/aa6e232bf170ad8b856aff9e7c70334f77441c7f Adaptation of patch from https://bitbucket.org/fenics-project/dolfin/issues/1116 --- a/dolfin/io/VTKFile.cpp +++ b/dolfin/io/VTKFile.cpp @@ -20,7 +20,7 @@ #include #include #include -#include +#include #include "pugixml.hpp" @@ -614,9 +614,9 @@ std::string endianness = ""; if (encode_string == "binary") { - #if defined BOOST_LITTLE_ENDIAN + #if defined BOOST_ENDIAN_LITTLE_BYTE endianness = "byte_order=\"LittleEndian\""; - #elif defined BOOST_BIG_ENDIAN + #elif defined BOOST_ENDIAN_BIG_BYTE endianness = "byte_order=\"BigEndian\"";; #else dolfin_error("VTKFile.cpp", --- a/dolfin/io/VTKWriter.cpp +++ b/dolfin/io/VTKWriter.cpp @@ -24,7 +24,6 @@ #include #include #include -#include #include #include a>
AgeCommit message (Expand)Author
2022-09-24system: image: Add wsl2 support....Alex Griffin
2022-09-24system: image: Add tarball support....Alex Griffin
2022-09-24image: Make the operating-system field mandatory....Mathieu Othacehe
2022-09-07image: Use #true and #false....Mathieu Othacehe
2022-09-07image: Use a default size partition value....Mathieu Othacehe
2022-08-31image: Add comments....Mathieu Othacehe
2022-08-30image: Remove an unused field....Mathieu Othacehe
2022-08-30image: Perform more sanitizing....Mathieu Othacehe
2022-07-01image: Add sanitizers for 'format' and 'partition-table-type'....Ludovic Courtès
2022-07-01image: Add default value for partition initializer....Ludovic Courtès
2022-05-25Move (gnu platform) and (gnu platforms ...) to guix/....Josselin Poiret
2021-12-23image: Add a shared-network? field....Mathieu Othacehe
2021-12-23image: Add a shared-store? field....Mathieu Othacehe
2021-11-12image: Support generating GPT images via `partition-table-type`....Ryan Sundberg
2021-10-11gnu: Add platform support....Mathieu Othacehe
2021-02-17image: Export image? procedure....Mathieu Othacehe
2020-09-30image: Add image-type support....Mathieu Othacehe