Add forward declarations.
--- fasthenry-3.0/src/fasthenry/sparse/spFactor.c.orig 2015-07-22 10:37:04.934043468 +0200
+++ fasthenry-3.0/src/fasthenry/sparse/spFactor.c 2015-07-22 12:52:55.515636802 +0200
@@ -105,7 +105,29 @@
#include "spDefs.h"
-
+static int FactorComplexMatrix( MatrixPtr );
+static CreateInternalVectors( MatrixPtr );
+static CountMarkowitz( MatrixPtr, register RealVector, int );
+static MarkowitzProducts( MatrixPtr, int );
+static ElementPtr SearchForPivot( MatrixPtr, int, int );
+static ElementPtr SearchForSingleton( MatrixPtr, int );
+static ElementPtr QuicklySearchDiagonal( MatrixPtr, int );
+static ElementPtr SearchDiagonal( MatrixPtr, register int );
+static ElementPtr SearchEntireMatrix( MatrixPtr, int );
+static RealNumber FindLargestInCol( register ElementPtr );
+static RealNumber FindBiggestInColExclude( MatrixPtr, register ElementPtr,
+ register int );
+static ExchangeRowsAndCols( MatrixPtr, ElementPtr, register int );
+static ExchangeColElements( MatrixPtr, int, register ElementPtr,
+ int, register ElementPtr, int );
+static ExchangeRowElements( MatrixPtr, int, register ElementPtr,
+ int, register ElementPtr, int );
+static RealRowColElimination( MatrixPtr, register ElementPtr );
+static ComplexRowColElimination( MatrixPtr, register ElementPtr );
+static UpdateMarkowitzNumbers( MatrixPtr, ElementPtr );
+static ElementPtr CreateFillin( MatrixPtr, register int, int );
+static int MatrixIsSingular( MatrixPtr, int );
+static int ZeroPivot( MatrixPtr, int );
e='d762e1c88c7a65417fed6f58a43bd312dc28ddcd'/>
log msg
author
committer
range
Age Commit message (Expand ) Author
2022-04-02 nls: Update translations. ...* po/packages/fi.po: New file.
* po/packages/LINGUAS: Add it.
Julien Lepiller
2022-03-01 nls: Update translations. ...* po/doc/guix-cookbook.uk.po: New file.
* po/doc/local.mk: Add uk cookbook.
* doc/local.mk: Add uk cookbook.
* po/guix/fa.po: New file.
* po/guix/uk.po: New file.
* po/guix/LINGUAS: Add fa and uk.
Julien Lepiller
2022-02-04 nls: Update translations. ...* po/doc/guix-cookbook.pt_BR.po: New file.
* po/doc/local.mk: Add it.
* doc/local.mk: Add pt_BR cookbook.
Julien Lepiller
2022-01-09 nls: Update translations. ...* po/doc/guix-cookbook.fi.po: New file.
* po/doc/guix-manual.fi.po: New file.
* po/doc/local.mk: Add them.
* doc/local.mk: Add them.
* po/guix/fi.po: New file.
* po/guix/LINGUAS: Add it.
Julien Lepiller
2021-12-04 nls: Update translations. Julien Lepiller
2021-11-06 nls: Update translations. ...* po/doc/guix-cookbook.es.po: New file.
* po/doc/local.mk: Add 'es' cookbook.
* doc/local.mk: Add 'es' cookbook.
Julien Lepiller
2021-10-17 nls: Update translations. Julien Lepiller
2021-09-02 nls: Update translations. ...* po/packages/it.po: New file.
* po/packages/LINGUAS: Add `it'.
* po/*/*.po: Update translations.
Julien Lepiller
2021-08-04 nls: Update translations. ...* po/doc/guix-cookbook.ru.po: New file.
* po/doc/guix-cookbook.sk.po: New file.
* po/*/*.po: Update translations.
* doc/local.mk (COOKBOOK_LANGUAGES): Add ru and sk.
(info_TEXINFOS): Add Russian and Slovak cookbooks.
* po/doc/local.mk (DOC_COOKBOOK_PO_FILES): Add Russian and Slovak po
files.
Julien Lepiller
2021-05-10 nls: New nl and oc translations for the 'packages' component. ...* po/packages/nl.po: New file.
* po/packages/oc.po: Likewise.
* po/packages/LINGUAS: Register them.
Maxim Cournoyer