Add forward declarations.
--- fastcap/src/mulSetup.c.orig 2015-07-22 13:55:21.592119775 +0200
+++ fastcap/src/mulSetup.c 2015-07-22 14:08:50.157688209 +0200
@@ -35,6 +35,14 @@
#include "mulGlobal.h"
+static getnbrs(ssystem*);
+static linkcubes(ssystem*);
+static setMaxq(ssystem*);
+static getAllInter(ssystem*);
+static set_vector_masks(ssystem*);
+static indexkid(ssystem*, cube*, int*, int*);
+static int placeq(int, ssystem*, charge*);
+
cube *cstack[1024]; /* Stack used in several routines. */
/*
ef='/'>index : guix
|
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2022-05-26 | cuirass: Create just as many threads as needed....* build-aux/cuirass/evaluate.scm (command-line): Change second argument
to 'n-par-for-each'.
| Ludovic Courtès |
2022-05-26 | cuirass: Fork inferior processes before creating threads....Works around <https://issues.guix.gnu.org/55441#12>.
Start from commit bd86bbd300474204878e927f6cd3f0defa1662a5,
'open-inferior' uses 'primitive-fork' instead of 'open-pipe*'. As a
result, child process could potentially hang before calling 'execl' due
to undefined behavior when forking a multi-threaded process.
* build-aux/cuirass/evaluate.scm <top level>: Call 'open-inferior'
before 'n-par-for-each'.
| Ludovic Courtès |
2022-05-20 | cuirass: Close each inferior upon completion....* build-aux/cuirass/evaluate.scm <top level>: Add 'close-inferior' call.
| Ludovic Courtès |