Add forward declarations. --- fastcap/src/mulSetup.c.orig 2015-07-22 13:55:21.592119775 +0200 +++ fastcap/src/mulSetup.c 2015-07-22 14:08:50.157688209 +0200 @@ -35,6 +35,14 @@ #include "mulGlobal.h" +static getnbrs(ssystem*); +static linkcubes(ssystem*); +static setMaxq(ssystem*); +static getAllInter(ssystem*); +static set_vector_masks(ssystem*); +static indexkid(ssystem*, cube*, int*, int*); +static int placeq(int, ssystem*, charge*); + cube *cstack[1024]; /* Stack used in several routines. */ /* ass='main'>index : guix
Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/services/vnc.scm
AgeCommit message (Collapse)Author
2023-05-21services: Transient inetd services inherit requirements.Ludovic Courtès
That way, per-connection transient services such as 'sshd-123' inherit dependencies of their "parent" ('sshd' in this example), which is more consistent than not depending on anything. * gnu/services/dict.scm (dicod-shepherd-service): Pass #:requirements to 'make-inetd-constructor'. * gnu/services/messaging.scm (bitlbee-shepherd-service): Likewise. * gnu/services/ssh.scm (openssh-shepherd-service): Likewise. * gnu/services/vnc.scm (xvnc-shepherd-service): Likewise.
2023-04-02services: xvnc: Do not create a regular HOME directory for xvnc user.Maxim Cournoyer
* gnu/services/vnc.scm (%xvnc-accounts) [home-directory]: Define as /var/empty. [shell]: Set to nologin, for good measures.
2022-10-07Revert "Revert "services: Add xvnc-service-type.""Maxim Cournoyer
This reverts commit 0c4966160054bc50e6ab3a4ac9c9a6a1826ab5a0. The fix appears in the subsequent commit, for clarity.
2022-10-07Revert "services: Add xvnc-service-type."Maxim Cournoyer
This reverts commit 1c528a95cb92b7808e6603d7956185005583629f. This broke 'guix pull', for (yet) unknown reasons.
2022-10-07services: Add xvnc-service-type.Maxim Cournoyer
* gnu/services/vnc.scm: New file. * gnu/tests/vnc.scm: Likewise. * gnu/local.mk: Register them.