From bc22f7d43c12c5f79c71b0319666e71f29d61322 Mon Sep 17 00:00:00 2001 From: =?UTF-8?q?Jakub=20K=C4=85dzio=C5=82ka?= Date: Mon, 25 May 2020 18:53:04 +0200 Subject: [PATCH] Disable self-update. Based on a Fedora patch by Elliott Sales de Andrade. --- cli/cli.go | 44 +------------------------------------------- 1 file changed, 1 insertion(+), 43 deletions(-) diff --git a/cli/cli.go b/cli/cli.go index 4312eb0..5f62297 100644 --- a/cli/cli.go +++ b/cli/cli.go @@ -10,13 +10,10 @@ import ( "io" "io/ioutil" "net/http" - "runtime" "strings" "time" "github.com/blang/semver" - "github.com/exercism/cli/debug" - update "github.com/inconshreveable/go-update" ) var ( @@ -95,46 +92,7 @@ func (c *CLI) IsUpToDate() (bool, error) { // Upgrade allows the user to upgrade to the latest version of the CLI. func (c *CLI) Upgrade() error { - var ( - OS = osMap[runtime.GOOS] - ARCH = archMap[runtime.GOARCH] - ) - - if OS == "" || ARCH == "" { - return fmt.Errorf("unable to upgrade: OS %s ARCH %s", OS, ARCH) - } - - buildName := fmt.Sprintf("%s-%s", OS, ARCH) - if BuildARCH == "arm" { - if BuildARM == "" { - return fmt.Errorf("unable to upgrade: arm version not found") - } - buildName = fmt.Sprintf("%s-v%s", buildName, BuildARM) - } - - var downloadRC *bytes.Reader - for _, a := range c.LatestRelease.Assets { - if strings.Contains(a.Name, buildName) { - debug.Printf("Downloading %s\n", a.Name) - var err error - downloadRC, err = a.download() - if err != nil { - return fmt.Errorf("error downloading executable: %s", err) - } - break - } - } - if downloadRC == nil { - return fmt.Errorf("no executable found for %s/%s%s", BuildOS, BuildARCH, BuildARM) - } - - bin, err := extractBinary(downloadRC, OS) - if err != nil { - return err - } - defer bin.Close() - - return update.Apply(bin, update.Options{}) + return fmt.Errorf("Please use Guix to update Exercism") } func (c *CLI) fetchLatestRelease() error { -- 2.26.2 uix/log/README?id=274bbce817ed66a343c33e3839e982bc14aa0257'>README
AgeCommit message (Expand)Author
2020-10-23doc: Update README....Maxim Cournoyer
2020-10-22README: Refer to the manual for building from Git....Maxim Cournoyer
2020-06-02doc: Update README to refer to the manual....Ludovic Courtès
2019-11-09doc: Mention value /var to localstatedir option....zimoun
2019-09-04doc: Update 'README'....Ludovic Courtès
2019-01-09build: Require Guile 2.2....Ludovic Courtès
2018-12-02Make Guile-JSON a required dependency....Eric Bavier
2018-11-23Update Guile-SQLite3 URL everywhere....Ludovic Courtès
2018-09-04Switch to Guile-Gcrypt....Ludovic Courtès
2018-06-27doc: Specify Guile-SQLite3 minimum version....Ludovic Courtès
2018-06-14build: Require Guile-SQLite3....Ludovic Courtès
2018-02-26build: Require Guile >= 2.0.13....Ludovic Courtès
2018-01-07doc: Mark zlib as mandatory, libbz2 as optional....Ludovic Courtès
2018-01-01doc: Update requirements in 'README'....Mathieu Lirzin
2017-09-25README: Replace http:// with https:// where applicable.Marius Bakke