Add $EUDEV_RULES_DIRECTORY to the list of rules directories. The old udev 182 supported $UDEV_CONFIG_FILE, which in turn allowed the search path to be customized, but eudev no longer has this, hence this hack. --- eudev-3.1.5/src/udev/udev-rules.c 2015-10-13 06:22:14.000000000 +0800 +++ eudev-3.1.5/src/udev/udev-rules.c 2015-10-16 20:45:38.491934336 +0800 @@ -47,15 +47,11 @@ }; }; -static const char* const rules_dirs[] = { +static const char* rules_dirs[] = { UDEV_CONF_DIR "/rules.d", UDEV_RULES_DIR, - UDEV_ROOT_RUN "/udev/rules.d", UDEV_LIBEXEC_DIR "/rules.d", -#ifdef HAVE_SPLIT_USR - "/lib/udev/rules.d", - "/usr/lib/udev/rules.d", -#endif + NULL, /* placeholder for $EUDEV_RULES_DIRECTORY */ NULL}; struct udev_rules { @@ -1704,6 +1700,9 @@ udev_rules_check_timestamp(rules); + /* Allow the user to specify an additional rules directory. */ + rules_dirs[3] = getenv("EUDEV_RULES_DIRECTORY"); + r = conf_files_list_strv(&files, ".rules", NULL, rules_dirs); if (r < 0) { log_error_errno(r, "failed to enumerate rules files: %m"); /log/gnu/system/uuid.scm'>logtreecommitdiff
path: root/gnu/system/uuid.scm
taller-log-line everywhere....
AgeCommit message (Expand)Author
2020-11-07uuid: Add support for bcachefs....Tobias Geerinckx-Rice
2020-07-26file-systems: Add NTFS support....Mathieu Othacehe
2020-06-18uuid: Prevent a loop on invalid arguments....Maxim Cournoyer
2020-01-03uuid: Add support for JFS....Tobias Geerinckx-Rice
2019-05-07uuid: 'fat-uuid->string' preserves leading zeros....Ludovic Courtès
Josselin Poiret
2022-01-14installer: Install the locale before mounting the cow-store....Mathieu Othacehe
2022-01-14installer: Do not set the locale in run-command....Mathieu Othacehe
2022-01-14installer: Remove an unused procedure....Mathieu Othacehe
2020-09-10installer: final: Introduce call-with-mnt-container....Mathieu Othacehe
2020-09-02installer: Run the installation inside a container....Mathieu Othacehe
2020-06-16installer: final: Remove restart-service procedure....Mathieu Othacehe
2020-06-13install: final: Add some logging....Mathieu Othacehe
2020-06-09installer: final: Dump "guix system init" command output when testing....Mathieu Othacehe
2020-06-09installer: final: Remove left-over pk call....Mathieu Othacehe
2020-06-05installer: final: Add some extra logging....Mathieu Othacehe