Add $EUDEV_RULES_DIRECTORY to the list of rules directories. The old udev 182 supported $UDEV_CONFIG_FILE, which in turn allowed the search path to be customized, but eudev no longer has this, hence this hack. --- eudev-3.1.5/src/udev/udev-rules.c 2015-10-13 06:22:14.000000000 +0800 +++ eudev-3.1.5/src/udev/udev-rules.c 2015-10-16 20:45:38.491934336 +0800 @@ -47,15 +47,11 @@ }; }; -static const char* const rules_dirs[] = { +static const char* rules_dirs[] = { UDEV_CONF_DIR "/rules.d", UDEV_RULES_DIR, - UDEV_ROOT_RUN "/udev/rules.d", UDEV_LIBEXEC_DIR "/rules.d", -#ifdef HAVE_SPLIT_USR - "/lib/udev/rules.d", - "/usr/lib/udev/rules.d", -#endif + NULL, /* placeholder for $EUDEV_RULES_DIRECTORY */ NULL}; struct udev_rules { @@ -1704,6 +1700,9 @@ udev_rules_check_timestamp(rules); + /* Allow the user to specify an additional rules directory. */ + rules_dirs[3] = getenv("EUDEV_RULES_DIRECTORY"); + r = conf_files_list_strv(&files, ".rules", NULL, rules_dirs); if (r < 0) { log_error_errno(r, "failed to enumerate rules files: %m"); e' href='/guix/log/gnu/services/telephony.scm'>logtreecommitdiff
path: root/gnu/services/telephony.scm
AgeCommit message (Expand)Author
2023-10-07services: configuration: Add some commonly used predicates....Bruno Victal
2023-10-07services: configuration: Use transducers within serialize-configuration....Bruno Victal
2023-02-08gnu: libjami: Move jamid daemon to a "bin" output....Maxim Cournoyer
2022-09-23services: jami-service-type: Streamline stop slot....Maxim Cournoyer
2022-08-25services: Use the new maybe/unset API....Attila Lendvai
2022-08-01services: configuration: Step back from *unspecified*....Maxim Cournoyer
2022-06-15services: configuration: Use *unspecified* instead of 'disabled....Attila Lendvai
2022-06-10services: jami-configuration: Rename 'jamid' field to 'libjami'....Maxim Cournoyer
2022-06-10services: jami: Modernize to adjust to Shepherd 0.9+ changes....Maxim Cournoyer
2022-04-12services: Replace murmur-service-type with mumble-server-service-type....Liliana Marie Prikler
2022-03-24services: murmur: Fix server program name....fesoj000
2022-01-13services: Adjust the jami service for the upgraded jami....Maxim Cournoyer
2021-11-30services: Accept <inferior-package>s in lieu of <package>s....Tobias Geerinckx-Rice