Add $EUDEV_RULES_DIRECTORY to the list of rules directories.
The old udev 182 supported $UDEV_CONFIG_FILE, which in turn allowed
the search path to be customized, but eudev no longer has this, hence
this hack.
--- a/src/udev/udev-rules.c
+++ b/src/udev/udev-rules.c
@@ -48,16 +48,11 @@ struct uid_gid {
};
};
-static const char* const rules_dirs[] = {
+static const char* rules_dirs[] = {
UDEV_CONF_DIR "/rules.d",
UDEV_RULES_DIR,
- UDEV_ROOT_RUN "/udev/rules.d",
UDEV_LIBEXEC_DIR "/rules.d",
-#ifdef HAVE_SPLIT_USR
- "/lib/udev/rules.d",
- "/usr/lib/udev/rules.d",
-#endif
- "/usr/local/lib/udev/rules.d",
+ NULL, /* placeholder for $EUDEV_RULES_DIRECTORY */
NULL};
struct udev_rules {
@@ -1718,6 +1713,9 @@ struct udev_rules *udev_rules_new(struct udev *udev, int resolve_names) {
udev_rules_check_timestamp(rules);
+ /* Allow the user to specify an additional rules directory. */
+ rules_dirs[3] = getenv("EUDEV_RULES_DIRECTORY");
+
r = conf_files_list_strv(&files, ".rules", NULL, rules_dirs);
if (r < 0) {
log_error_errno(r, "failed to enumerate rules files: %m");
href='/guix/tree/gnu/services/nix.scm?id=f46ae49b13b78e054e402db778a86ccfafdf7eab'>treecommitdiff
|
Age | Commit message (Expand) | Author |
2021-04-26 | services: nix: Add /bin/sh to build-sandbox-paths....Fixes <https://bugs.gnu.org/46297>.
* gnu/services/nix.scm (nix-service-etc): Add /bin/sh to build-sandbox-paths.
| Oleg Pykhalov |
2020-12-06 | services: nix: Move nix.conf generation to etc-service-type..../etc/nix/nix.conf is a static file doesn't need rebuild on every boot.
* gnu/services/nix.scm (nix-activation): Don't create /etc/nix/nix.conf.
(nix-service-etc): New function.
(nix-service-type): New service-extension "nix-service-etc" to etc-service-type.
Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
| Zhu Zihao |
2020-07-25 | services: nix: Add extra-options....* gnu/services/nix.scm (<nix-configuration>)[extra-options]: New field.
(nix-shepherd-service): Add this.
(nix-activation): Add new line to the end of /etc/nix/nix.conf file.
* doc/guix.texi (Miscellaneous Services)[Nix service]: Document this.
| Oleg Pykhalov |
2020-07-25 | services: nix: Fix typo....* gnu/services/nix.scm (<nix-configuration>): Fix typo.
| Oleg Pykhalov |
2020-07-25 | services: nix: Export nix-configuration....* gnu/services/nix.scm (nix-configuration, nix-configuration?): Export.
Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
| Peng Mei Yu |
2020-07-25 | services: nix: Provide nix commands....* gnu/services/nix.scm (nix-service-type): Extend profile-service-type to
provide nix commands.
Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
| Peng Mei Yu via Guix-patches via |
2020-07-22 | services: nix: Fix sandbox....* gnu/tests/package-management.scm: New file.
* gnu/local.mk: Add this.
* gnu/services/nix.scm (<nix-configuration>): New record.
(nix-activation): Generate Nix config file which fixes sandbox.
(nix-service-type): Add default value.
(nix-shepherd-service): Allow provide Nix package.
* doc/guix.texi (Miscellaneous Services)[Nix service]<nix-configuration>:
Document record.
| Oleg Pykhalov |
2020-06-25 | services: Add missing (ice-9 format) import....These issues were reported by -Wformat, though they were harmless in
practice because importing (ice-9 format) changes the global 'format'
binding currently.
* gnu/services/nix.scm: Import (ice-9 format).
* gnu/services/web.scm: Likewise.
* gnu/system/mapped-devices.scm: Likewise.
| Ludovic Courtès |