Don't clutter /tmp with logs.
---
EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp | 10 ++--------
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp b/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
index 56c655dc..2750f5a6 100644
--- a/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
+++ b/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
@@ -1013,14 +1013,8 @@ void Logger::OpenLogfile(std::string filename)
file_.open(filename.c_str());
if (file_.fail())
{
- const char* filename_tmp = std::tmpnam(NULL);
- printf("Cannot open log file: %s in working directory. Trying system tmp-file: %s\n",
- SE_Env::Inst().GetLogFilePath().c_str(), filename_tmp);
- file_.open(filename_tmp);
- if (file_.fail())
- {
- printf("Also failed to open log file: %s. Continue without logfile, still logging to console.\n", filename_tmp);
- }
+ printf("Cannot open log file: %s in working directory. Continuing without logfile, still logging to console.\n",
+ filename.c_str());
}
}
#endif
--
2.38.1
2d2155cc28fb8c8d032e21aab7ec19ec606f7a8'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2023-10-09 | gnu: imgui@1.86: Adjust make-flags....* gnu/packages/toolkits.scm (imgui-1.86)[arguments]: Remove the
"-DIMGUI_ENABLE_FREETYPE" make-flag which breaks the display of mangohud, the
only dependent. The "-DImDrawIdx=unsigned int" make-flag was previously
removed, so we can do both by filtering make-flags starting with "-D".
[inputs]: Remove freetype.
| John Kehayias |
2023-09-26 | gnu: imgui: Update to 1.89.9....* gnu/packages/toolkits.scm (imgui): Update to 1.89.9.
| Maxim Cournoyer |
2023-09-26 | gnu: imgui: Enable freetype support....* gnu/packages/toolkits.scm (imgui) [arguments]: Add -DIMGUI_ENABLE_FREETYPE
to make flags.
[inputs]: Add freetype.
| Maxim Cournoyer |