Don't clutter /tmp with logs.
---
EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp | 10 ++--------
1 file changed, 2 insertions(+), 8 deletions(-)
diff --git a/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp b/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
index 56c655dc..2750f5a6 100644
--- a/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
+++ b/EnvironmentSimulator/Modules/CommonMini/CommonMini.cpp
@@ -1013,14 +1013,8 @@ void Logger::OpenLogfile(std::string filename)
file_.open(filename.c_str());
if (file_.fail())
{
- const char* filename_tmp = std::tmpnam(NULL);
- printf("Cannot open log file: %s in working directory. Trying system tmp-file: %s\n",
- SE_Env::Inst().GetLogFilePath().c_str(), filename_tmp);
- file_.open(filename_tmp);
- if (file_.fail())
- {
- printf("Also failed to open log file: %s. Continue without logfile, still logging to console.\n", filename_tmp);
- }
+ printf("Cannot open log file: %s in working directory. Continuing without logfile, still logging to console.\n",
+ filename.c_str());
}
}
#endif
--
2.38.1
31f5cb823755eb792f2e9ee'>refslogtreecommitdiff
|
Age | Commit message (Expand) | Author |
2018-06-01 | bootloader: grub: Use 'with-extensions'....* gnu/bootloader/grub.scm (svg->png): Use 'with-extensions'. Remove
'add-to-load-path' calls.
* gnu/build/svg.scm: Use (rsvg) and (cairo) the normal way. Remove
'module-autoload!' calls.
| Ludovic Courtès |
2017-07-02 | gnu: Switch guile-cairo and dependents to Guile 2.2 again....Fixes <https://bugs.gnu.org/27551>.
Reported by Leo Famulari <leo@famulari.name>.
This reinstates the following commits:
e3ddb1e83 * gnu: guile-cairo: Switch to Guile 2.2.
ae5c6ef39 * gnu: guile-gnome: Update to 2.16.5.
0fd8013fc * gnu: guile-rsvg: Update to commit 05c6a2fd.
66b9183c4 * gnu: guile-lib: Switch to Guile 2.2.
and adds the following changes:
* gnu/bootloader/grub.scm (svg->png): Add 'package->derivation' call for
GUILE-2.2. Pass #:guile-for-build to 'gexp->derivation'.
* gnu/build/svg.scm (svg->png): Add 'em' and 'ex' to the 'let-values'
form to account for all the values returned by
'rsvg-handle-get-dimensions', which Guile 2.2 does not truncate.
| Ludovic Courtès |
2016-10-25 | svg: Autoload Guile-RSVG and Guile-Cairo....Fixes compilation by 'guix pull' where Guile-{RSVG,Cairo} are missing.
Reported by Efraim Flashner.
* gnu/build/svg.scm: Use 'module-autoload!' rather than 'module-use!'.
| Ludovic Courtès |
2016-10-25 | system: grub: Use Guile-{RSVG,Cairo} instead of Inkscape + ImageMagick....Based on a suggestion by Andy Wingo at
<https://lists.gnu.org/archive/html/guix-devel/2015-08/msg00753.html>.
* gnu/build/svg.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
* gnu/system/grub.scm (svg->png): Add #:width and #:height. Rewrite to
use (gnu build svg).
(resize-image): Remove.
(grub-background-image): Adjust accordingly.
| Ludovic Courtès |