Patch originally from https://sources.debian.net/patches/erlang/1:20.0.1%2Bdfsg-2/man.patch/ by Francois-Denis Gonthier . Patch description rewritten for Guix. This patch allows access to the man page with the 'erl -man' command (Erlang manual pages are placed to /gnu/store/..erlang../share/man/ hierarchy as other man pages.) --- a/erts/etc/common/erlexec.c +++ b/erts/etc/common/erlexec.c @@ -709,8 +709,10 @@ error("-man not supported on Windows"); #else argv[i] = "man"; - erts_snprintf(tmpStr, sizeof(tmpStr), "%s/man", rootdir); - set_env("MANPATH", tmpStr); + /* + * Conform to erlang-manpages content. + */ + putenv(strsave("MANSECT=1:3:5:7")); execvp("man", argv+i); error("Could not execute the 'man' command."); #endif Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/nix/libstore/build.cc
AgeCommit message (Expand)Author
2024-03-12daemon: Address shortcoming in previous security fix for CVE-2024-27297....Ludovic Courtès
2024-03-11daemon: Protect against FD escape when building fixed-output derivations (CVE......Ludovic Courtès
2023-12-17daemon: Fix my own whitespace errors....Tobias Geerinckx-Rice
2023-12-10daemon: Sacrifice builders on OOM....Tobias Geerinckx-Rice
2023-12-04daemon: Simplify “empty status” substitute error message....Ludovic Courtès
2022-12-18daemon: Make "opening file" error messages distinguishable....Ludovic Courtès
2022-06-05daemon: Quote consistently within a string....Tobias Geerinckx-Rice
2022-05-29daemon: Clarify ‘--check’ error when outputs are missing....Tobias Geerinckx-Rice
2022-05-18daemon: runChild() is forbidden to talk during environment set up...yarl-baudig@mailoo.org