From bfcd616f2870c8c3ffc9a526fcd574eb5e726a96 Mon Sep 17 00:00:00 2001 From: Andrew Tropin Date: Sat, 14 Jan 2023 09:33:34 +0400 Subject: [PATCH] Add path placeholder for telega-server-command and etc-file. --- telega-core.el | 2 +- telega-customize.el | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/telega-core.el b/telega-core.el index 36f121e..f9f7976 100644 --- a/telega-core.el +++ b/telega-core.el @@ -41,7 +41,7 @@ (defun telega-etc-file (filename) "Return absolute path to FILENAME from etc/ directory in telega." - (expand-file-name (concat "etc/" filename) telega--lib-directory)) + (concat "@TELEGA_SHARE@" "/" filename)) (defconst telega-spoiler-translation-table (let ((table (make-char-table 'translation-table))) diff --git a/telega-customize.el b/telega-customize.el index 0efb001..77cec5f 100644 --- a/telega-customize.el +++ b/telega-customize.el @@ -633,7 +633,7 @@ In range [1..3]. Use 1." :prefix "telega-server-" :group 'telega) -(defcustom telega-server-command "telega-server" +(defcustom telega-server-command "@TELEGA_SERVER_BIN@" "Command to run as telega server. It should be absolute path or binary file searchable in `exec-path'." :type 'string -- 2.38.1 6a322e5d3d45088'>treecommitdiff
path: root/tests/packages.scm
AgeCommit message (Expand)Author
2023-09-15tests: Fix "package-transitive-supported-systems, implicit inputs"....Janneke Nieuwenhuizen
2023-08-18tests: packages: Set system for expected result of package->bag....Josselin Poiret
2023-06-14packages: 'package-transitive-supported-systems' detects cycles....Ludovic Courtès
2023-04-19tests: Re-add debug output to a package tests....Maxim Cournoyer
2023-03-13packages: 'package-input-rewriting/spec' ignores hidden packages....Ludovic Courtès
2023-03-13packages: Consider 'patches' by 'package-direct-sources'....Simon Tournier
2022-12-13packages: Add 'package-upstream-name*'....Lars-Dominik Braun
2022-11-11grafts: Run with a UTF-8 locale....Ludovic Courtès
2022-10-22Remove now unnecessary uses of (guix grafts)....Ludovic Courtès
2022-10-10packages: Raise an exception for invalid 'license' values....Ludovic Courtès
2022-04-04packages: Add 'package-unique-version-prefix'....Ludovic Courtès
2022-03-16packages: 'modify-inputs' preserves outputs in 'replace' clauses....Ludovic Courtès
2022-03-16tests: Exercise 'modify-inputs' with a 'replace' clause....Ludovic Courtès
2022-02-18packages: 'package-transitive-supported-systems' ignores '%current-target-sys......Ludovic Courtès
2022-02-11tests: Pass #:guile to 'computed-file' & co....Ludovic Courtès