Remove interactive build for telega-server, as it fails on Guix. Modify the `telega-server--find-bin' function to only use the version of telega-server installed by Guix. Created by Brett Gilio --- a/telega-server.el +++ b/telega-server.el @@ -113,7 +113,6 @@ If already deferring, then just executes the BODY." If BUILD-FLAGS is specified, then rebuild server without any queries using this flags for building, could be empty string. Otherwise query user about building flags." - (interactive) (telega-test-env 'quiet) (when (or build-flags (y-or-n-p "Build `telega-server'? ")) @@ -137,11 +136,8 @@ Otherwise query user about building flags." (defun telega-server--find-bin () "Find telega-server executable. Raise error if not found." - (let ((exec-path (cons telega-directory exec-path))) - (or (executable-find "telega-server") - (progn (telega-server-build) - (executable-find "telega-server")) - (error "`telega-server' not found in exec-path")))) + (or (executable-find "telega-server") + (error "`telega-server' not found in exec-path"))) (defun telega-server-version () "Return telega-server version." me-development.scm'>logtreecommitdiff
path: root/gnu/packages/game-development.scm
AgeCommit message (Expand)Author
2019-11-12gnu: openvr: Update to 1.8.19....* gnu/packages/game-development.scm (openvr): Update to 1.8.19. Tobias Geerinckx-Rice
2019-10-30gnu: Fix attribution....* gnu/packages/game-development.scm: Fix attribution. Nicolas Goaziou
2019-10-30gnu: Add renpy....* gnu/packages/game-development: (python2-pygame-sdl2): New variable. (python2-renpy): New variable. (renpy): New variable. Comrade Yuri
2019-10-29gnu: love: Update to 11.3....* gnu/packages/game-development.scm (love): Update to 11.3. Tobias Geerinckx-Rice
2019-10-17gnu: tiled: Update to 1.2.5....* gnu/packages/game-development.scm (tiled): Update to 1.2.5. Tobias Geerinckx-Rice
2019-09-24gnu: Move openmw-openscenegraph to graphics.scm....Package inheritance across modules may cause unbound variable errors at expansion time because of cyclic dependencies between the modules. * gnu/packages/game-development.scm (openmw-openscenegraph): Move from here ... * gnu/packages/graphics.scm (openmw-openscenegraph): ... to here. Make the variable public and "hide" the package. Marius Bakke
2019-09-24gnu: openmw: Use OpenMW's fork of openscenegraph....* gnu/packages/game-development.scm (openmw)[inputs]: Replace openscenegraph with openmw-openscenegraph. Pierre Neidhardt
2019-09-07gnu: nml: Fix for newer pillow version....* gnu/packages/game-development.scm (nml)[arguments]: Add a phase to fix for newer pillow. Julien Lepiller
2019-07-10gnu: plib: Fix CVE-2011-4620, CVE-2012-4552....* gnu/packages/game-development.scm (plib)[patches]: Add patches. * gnu/packages/patches/plib-CVE-2011-4620.patch, gnu/packages/patches/plib-CVE-2012-4552.patch: New files. * gnu/local.mk (dist_patch_DATA): Register them. Efraim Flashner