Honor SOURCE_DATE_EPOCH variable to avoid non-determinism in generated "autoloads" files. --- a/lisp/emacs-lisp/autoload.el +++ b/lisp/emacs-lisp/autoload.el @@ -419,8 +419,12 @@ ;; nil t)) ;; (match-end 2)))) (insert generate-autoload-section-header) - (prin1 `(autoloads ,autoloads ,load-name ,file ,time) - outbuf) + (let* ((env (getenv "SOURCE_DATE_EPOCH")) + (time (if env + (seconds-to-time (string-to-number env)) + time))) + (prin1 `(autoloads ,autoloads ,load-name ,file ,time) + outbuf)) (terpri outbuf) ;; Break that line at spaces, to avoid very long lines. ;; Make each sub-line into a comment. submit();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/bootloader.scm
AgeCommit message (Expand)Author
2019-08-30system: Add 'bootloader-menu-entries' field to <boot-parameters>....Ludovic Courtès
2019-08-30bootloader: Fix comment about 'menu-entries'....Ludovic Courtès
2019-03-24bootloader: Add a 'keyboard-layout' field....Ludovic Courtès
2019-03-24bootloader: Reindent record type definition....Ludovic Courtès
2019-03-24bootloader: Remove unused 'additional-configuration' field....Ludovic Courtès
2019-01-16bootloader: Remove deprecated 'device' field....Ludovic Courtès
2018-04-08discovery: Remove dependency on (guix ui)....Ludovic Courtès