Honor SOURCE_DATE_EPOCH variable to avoid non-determinism in generated "autoloads" files. --- a/lisp/emacs-lisp/autoload.el +++ b/lisp/emacs-lisp/autoload.el @@ -378,8 +378,12 @@ "Insert the section-header line, which lists the file name and which functions are in it, etc." (insert generate-autoload-section-header) - (prin1 `(autoloads ,autoloads ,load-name ,file ,time) - outbuf) + (let* ((env (getenv "SOURCE_DATE_EPOCH")) + (time (if env + (seconds-to-time (string-to-number env)) + time))) + (prin1 `(autoloads ,autoloads ,load-name ,file ,time) + outbuf)) (terpri outbuf) ;; Break that line at spaces, to avoid very long lines. ;; Make each sub-line into a comment. ko' selected='selected'>koszko Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/linux-boot.scm
8ff43b959c258ed92531029a1c82fa7'>tests: Adjust for removal of 'device' field in <bootloader-configuration>....
AgeCommit message (Expand)Author
2019-03-24system: Initialize console keyboard layout in the initrd....Ludovic Courtès
Ludovic Courtès
2019-01-11services: Deprecate a few more service procedures....Ludovic Courtès
2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès
2018-09-07vm: Make UUID computation really deterministic....Ludovic Courtès
2018-05-28system: Remove uses of the 'title' field of <file-system>....Ludovic Courtès
2018-05-19tests: Adjust to new "unbound variable" messages....Ludovic Courtès
2018-04-30guix system: search: Display default Shepherd service names....Ludovic Courtès
2018-03-24tests: Add tests for "guix system disk-image" et al....Chris Marusich
2017-12-06gnu, doc, tests: Use ‘bootloader-configuration’ everywhere....Tobias Geerinckx-Rice
2017-12-04tests: Look for multi-digit column numbers in unbound variable test....Eric Bavier
2017-11-10tests: Adjust to unbound-variable exception printer....Ludovic Courtès
2017-11-08gnu: Improve error reporting of the use-.*modules macros....Ludovic Courtès
2017-10-10ui: Improve reporting of missing closing parentheses....Ludovic Courtès
2017-09-16guix system: Add 'search' command....Ludovic Courtès
2017-03-15tests: Expect less accurate location info in 2.2.0....Ludovic Courtès
2016-07-20tests: Adjust to Shepherd error message change....Ludovic Courtès