From 6e8cb6f2175cd5c108de615a970a27877adfaea0 Mon Sep 17 00:00:00 2001 From: Maxim Cournoyer Date: Fri, 19 Jan 2024 10:49:51 -0500 Subject: [PATCH] tests: Fix byte-compilation test. * test/shx-test.el (shx-test-unit-byte-compile): Simply assert on the return value of byte-compile-file, which is non-nil when there are no errors. Fixes: --- test/shx-test.el | 4 +--- 1 file changed, 1 insertion(+), 3 deletions(-) diff --git a/test/shx-test.el b/test/shx-test.el index e18cefb..ed5aee3 100644 --- a/test/shx-test.el +++ b/test/shx-test.el @@ -83,10 +83,8 @@ Example: "Test byte-compilation against the shx.el file." (ignore-errors (kill-buffer "*Compile-Log*")) (let ((file (replace-regexp-in-string ".elc$" ".el" (symbol-file 'shx-mode)))) - (byte-compile-file file) (shx-test-assert "shx.el passes byte-compilation" - (with-current-buffer (get-buffer-create "*Compile-Log*") - (<= (- (point-max) (point)) 3))))) + (byte-compile-file file)))) (defun shx-test-unit-declare-function () "Test `declare-function'." base-commit: b99d16f36bc278d668d8428c4bc9af77064c336a -- 2.41.0 175c8bd3aecd837f1b0cd266e0deab177f40'>treecommitdiff
AgeCommit message (Expand)Author
2024-07-15gnu: tls: Raise conditions from target->openssl-target....Christopher Baines
2024-06-11gnu: libressl: Run tests under ‘datefudge’....Ludovic Courtès
2024-04-30gnu: guile-gnutls: Update to 4.0.0....Christopher Baines
2024-02-05gnu: Add mbedtls, version 3.5.2....Hilton Chain
2024-02-05gnu: mbedtls-apache: Rename to mbedtls-lts....Hilton Chain
2024-02-05gnu: mbedtls-apache: Use gexps....Hilton Chain
2024-02-05gnu: mbedtls-apache: Update to 2.28.7....Hilton Chain
2024-02-05gnu: mbedtls-for-hiawatha: Update package style....Hilton Chain
2024-02-05gnu: mbedtls-for-hiawatha: Use inherited source....Hilton Chain
2024-01-20gnu: gnutls: Update to 3.8.3 [security-fixes]....Jack Hill
2024-01-11gnu: Update guile-gnutls to 3.7.14....David Thompson
2024-01-05gnutls: Update to 3.8.2 (fixes CVE-2023-5981)....Maxim Cournoyer
2024-01-04gnu: openssl: Fix building on x86_64-linux-gnux32....Efraim Flashner