Copyright © 2018 Oleg Pykhalov This patch fixes tests for Emacs 25. Upstream bug URL: https://github.com/gongo/json-reformat/issues/33 diff --git a/test/json-reformat-test.el b/test/json-reformat-test.el index 7de3be1..b4a4dde 100644 --- a/test/json-reformat-test.el +++ b/test/json-reformat-test.el @@ -58,7 +58,7 @@ (ert-deftest json-reformat-test:string-to-string () (should (string= "\"foobar\"" (json-reformat:string-to-string "foobar"))) (should (string= "\"fo\\\"o\\nbar\"" (json-reformat:string-to-string "fo\"o\nbar"))) - (should (string= "\"\\u2661\"" (json-reformat:string-to-string "\u2661"))) + (should (string= "\"♡\"" (json-reformat:string-to-string "\u2661"))) (should (string= "\"^(amq\\\\.gen.*|amq\\\\.default)$\"" (json-reformat:string-to-string "^(amq\\.gen.*|amq\\.default)$"))) ) @@ -148,6 +148,6 @@ bar\"" (json-reformat:string-to-string "fo\"o\nbar"))) [{ foo : \"bar\" }, { \"foo\" : \"baz\" }]") ;; At 3 (line) (json-reformat-region (point-min) (point-max))) (should (string= - "JSON parse error [Reason] Bad string format: \"doesn't start with '\\\"'!\" [Position] In buffer, line 3 (char 6)" + "JSON parse error [Reason] Bad string format: \"doesn't start with \`\\\"'!\" [Position] In buffer, line 3 (char 6)" message-string)) ))) -- 2.15.1 3533973fd90243ad5502b49d7a7'>diff
path: root/build-aux
AgeCommit message (Expand)Author
2024-01-05build: test-driver.scm: Set mode....Tomas Volf
2023-08-21maint: Add 'etc/hurd-manifest.scm'....Janneke Nieuwenhuizen
2023-07-25cuirass: Update hurd-manifest with newly supported packages....Janneke Nieuwenhuizen
2022-05-26cuirass: Create just as many threads as needed....Ludovic Courtès
2022-05-26cuirass: Fork inferior processes before creating threads....Ludovic Courtès
2022-05-20cuirass: Close each inferior upon completion....Ludovic Courtès
2021-12-22tests: Move keys into ./tests/keys/ and add a third ed25519 key....Attila Lendvai
2021-11-27build-self: Help users to submit useful bug reports....Tobias Geerinckx-Rice
2021-10-17maint: Factorize po xref translation....Julien Lepiller
2021-06-23build: Makefile splits Scheme compilation in four steps....Ludovic Courtès
2021-06-18build: Remove Guile 2.2 workaround....Ludovic Courtès
2021-05-11Merge branch 'version-1.3.0'Maxim Cournoyer
2021-05-10maint: update-NEWS: Sort packages prior writing to the data file....Maxim Cournoyer