Copyright © 2018 Oleg Pykhalov This patch fixes tests for Emacs 25. Upstream bug URL: https://github.com/gongo/json-reformat/issues/33 diff --git a/test/json-reformat-test.el b/test/json-reformat-test.el index 7de3be1..b4a4dde 100644 --- a/test/json-reformat-test.el +++ b/test/json-reformat-test.el @@ -58,7 +58,7 @@ (ert-deftest json-reformat-test:string-to-string () (should (string= "\"foobar\"" (json-reformat:string-to-string "foobar"))) (should (string= "\"fo\\\"o\\nbar\"" (json-reformat:string-to-string "fo\"o\nbar"))) - (should (string= "\"\\u2661\"" (json-reformat:string-to-string "\u2661"))) + (should (string= "\"♡\"" (json-reformat:string-to-string "\u2661"))) (should (string= "\"^(amq\\\\.gen.*|amq\\\\.default)$\"" (json-reformat:string-to-string "^(amq\\.gen.*|amq\\.default)$"))) ) @@ -148,6 +148,6 @@ bar\"" (json-reformat:string-to-string "fo\"o\nbar"))) [{ foo : \"bar\" }, { \"foo\" : \"baz\" }]") ;; At 3 (line) (json-reformat-region (point-min) (point-max))) (should (string= - "JSON parse error [Reason] Bad string format: \"doesn't start with '\\\"'!\" [Position] In buffer, line 3 (char 6)" + "JSON parse error [Reason] Bad string format: \"doesn't start with \`\\\"'!\" [Position] In buffer, line 3 (char 6)" message-string)) ))) -- 2.15.1 d629c7582a5b6da17bf40ba7370ecfbf6170'>diff
path: root/gnu
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-08-15 00:15:11 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-08-15 00:23:16 +0200
commit06d8d629c7582a5b6da17bf40ba7370ecfbf6170 (patch)
tree6dc5c3d80a304645c5becd048d6d024262cd7f32 /gnu
parentfa30df8a6570c3635566d9f18cd60e69fe82a057 (diff)
downloadguix-06d8d629c7582a5b6da17bf40ba7370ecfbf6170.tar.gz
guix-06d8d629c7582a5b6da17bf40ba7370ecfbf6170.zip
gnu: emacs-autothemer: Update to 0.2.5.
* gnu/packages/emacs-xyz.scm (emacs-autothemer): Update to 0.2.5.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index c125452841..de98c83fd9 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm