Copyright © 2018 Oleg Pykhalov This patch fixes tests for Emacs 25. Upstream bug URL: https://github.com/gongo/json-reformat/issues/33 diff --git a/test/json-reformat-test.el b/test/json-reformat-test.el index 7de3be1..b4a4dde 100644 --- a/test/json-reformat-test.el +++ b/test/json-reformat-test.el @@ -58,7 +58,7 @@ (ert-deftest json-reformat-test:string-to-string () (should (string= "\"foobar\"" (json-reformat:string-to-string "foobar"))) (should (string= "\"fo\\\"o\\nbar\"" (json-reformat:string-to-string "fo\"o\nbar"))) - (should (string= "\"\\u2661\"" (json-reformat:string-to-string "\u2661"))) + (should (string= "\"♡\"" (json-reformat:string-to-string "\u2661"))) (should (string= "\"^(amq\\\\.gen.*|amq\\\\.default)$\"" (json-reformat:string-to-string "^(amq\\.gen.*|amq\\.default)$"))) ) @@ -148,6 +148,6 @@ bar\"" (json-reformat:string-to-string "fo\"o\nbar"))) [{ foo : \"bar\" }, { \"foo\" : \"baz\" }]") ;; At 3 (line) (json-reformat-region (point-min) (point-max))) (should (string= - "JSON parse error [Reason] Bad string format: \"doesn't start with '\\\"'!\" [Position] In buffer, line 3 (char 6)" + "JSON parse error [Reason] Bad string format: \"doesn't start with \`\\\"'!\" [Position] In buffer, line 3 (char 6)" message-string)) ))) -- 2.15.1 tils.scm?id=35c8d631d2bd63c64e863b5509f29fdcb7f856e6'>commitdiff
path: root/gnu/packages/password-utils.scm
AgeCommit message (Expand)Author
2023-07-22gnu: tessen: Update to 2.2.1....Hilton Chain
2023-07-16gnu: yapet: Fix documentation directory....Tobias Geerinckx-Rice
2023-07-16gnu: yapet: Update to 2.6....Tobias Geerinckx-Rice
2023-07-16gnu: passwdqc: Update to 2.0.3....Tobias Geerinckx-Rice
2023-07-16gnu: otpclient: Update to 3.1.9....Tobias Geerinckx-Rice
2023-07-16gnu: hydra: Update to 9.5....Tobias Geerinckx-Rice
2023-07-11gnu: keepassxc: Fix broken home-page url....jgart
2023-07-05gnu: Add passwdqc....flabbergasted
2023-07-01gnu: password-store: Fix program name in usage and tmpdir....Tobias Kortkamp
2023-06-14gnu: browserpass-native: Use new package style....Timotej Lazar
2023-06-14gnu: browserpass-native: Update to 3.1.0....Timotej Lazar
2023-06-11gnu: Add otpclient....Liliana Marie Prikler
2023-06-04gnu: keepassxc: Update to 2.7.5....Efraim Flashner