Fix contributed upstream here: https://debbugs.gnu.org/cgi/bugreport.cgi?bug=42694. Index: emacs-26.3/src/xfns.c =================================================================== --- emacs-26.3.orig/src/xfns.c +++ emacs-26.3/src/xfns.c @@ -2628,6 +2628,8 @@ xic_free_xfontset (struct frame *f) static XIMStyle best_xim_style (XIMStyles *xim) { + if (xim == NULL) goto out; + int i, j; int nr_supported = ARRAYELTS (supported_xim_styles); @@ -2636,6 +2638,7 @@ best_xim_style (XIMStyles *xim) if (supported_xim_styles[i] == xim->supported_styles[j]) return supported_xim_styles[i]; + out: /* Return the default style. */ return XIMPreeditNothing | XIMStatusNothing; } ();'> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/tests/hackage.scm
AgeCommit message (Expand)Author
2021-05-22import: hackage: Prefix licenses with 'license:'....Xinglu Chen
2019-06-20import: hackage: Add two expected failing test cases....Robert Vollmert
2019-06-13import: hackage: Handle Hackage revisions....Robert Vollmert
2019-06-02import: hackage: Parse braced properties....Robert Vollmert
2019-06-02tests: hackage: Test multiline cabal description....Robert Vollmert
2019-06-02tests: Fix hackage tests....Robert Vollmert
2019-06-01tests: Indent hackage tests...Robert Vollmert
2019-06-01tests: hackage: Don't mock hackage-fetch....Robert Vollmert
2019-06-01tests: hackage: Factor out package pattern....Robert Vollmert
2019-05-26import: hackage: Fix Cabal test....Ludovic Courtès