Copyright © 2017 Oleg Pykhalov Copyright © 2017 Ludovic Courtès This patch adds highlighting for (guix) G-Expressions. diff --git a/highlight-stages.el b/highlight-stages.el index 3094c3c..e11260e 100644 --- a/highlight-stages.el +++ b/highlight-stages.el @@ -237,14 +237,14 @@ non-nil, (match-string 0) must be the expression matched." (defun highlight-stages-lisp-quote-matcher (&optional limit) (when (highlight-stages--search-forward-regexp - "\\(?:`\\|\\(#?'\\)\\)\\|([\s\t\n]*\\(?:backquote\\|\\(quote\\)\\)[\s\t\n]+" limit) + "\\(?:`\\|\\(#?'\\)\\)\\|([\s\t\n]*\\(?:backquote\\|\\(quote\\)\\)[\s\t\n]+\\|\\(?:#~\\)\\|([\s\t\n]*\\(?:gexp\\)[\s\t\n]+" limit) (prog1 (if (or (match-beginning 1) (match-beginning 2)) 'real t) (set-match-data (list (point) (progn (ignore-errors (forward-sexp 1)) (point))))))) (defun highlight-stages-lisp-escape-matcher (&optional limit) - (when (highlight-stages--search-forward-regexp ",@?\\|([\s\t\n]*\\\\,@?+[\s\t\n]+" limit) + (when (highlight-stages--search-forward-regexp ",@?\\|([\s\t\n]*\\\\,@?+[\s\t\n]+\\|\\(unquote\\)\\|\\(unquote-splicing\\)\\|\\(ungexp-native\\)\\|\\(ungexp-splicing\\)\\|\\(ungexp-native-splicing\\)\\|\\(ungexp\\)\\|#\\$" limit) (set-match-data (list (point) (progn (ignore-errors (forward-sexp 1)) (point)))) diff
AgeCommit message (Expand)Author
2017-04-20mailmap: Update entries for ng0....ng0
2017-01-27Update .mailmap entries for ng0....ng0
2017-01-01Update .mailmap....Alex Kost
2016-12-20mailmap: Add alias for Marius Bakke....Marius Bakke
2016-11-26mailmap: Associate all commits by ng0 with ng0....ng0
2016-10-11Update e-mail address for ng0....ng0
2016-10-05Update e-mail address for ng0....ng0
2016-07-15Update e-mail address for Tobias Geerinckx-Rice....Andreas Enge
2016-07-03Update name for ng0....ng0
2016-05-19Update name for Kei Kebreau....Kei Kebreau
2016-05-04Update .mailmap....Alex Kost
2016-03-24Update .mailmap....Alex Kost