Fix 'scheme-indent-function' to indent s-expressions starting with a keyword properly, like this: (#:foo 1 #:bar 2) instead of like this: (#:foo 1 #:bar 2) The fix is made by Mark H Weaver : --- a/lisp/progmodes/scheme.el +++ b/lisp/progmodes/scheme.el @@ -494,6 +494,12 @@ indentation." (> (length function) 3) (string-match "\\`def" function))) (lisp-indent-defform state indent-point)) + ((and (null method) + (> (length function) 1) + ;; The '#' in '#:' seems to get lost, not sure why + (string-match "\\`:" function)) + (let ((lisp-body-indent 1)) + (lisp-indent-defform state indent-point))) ((integerp method) (lisp-indent-specform method state indent-point normal-indent)) able class='tabs'> aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-06-14 10:37:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-06-14 14:45:19 +0300
commita5daa8c0ab400bffc53f245069a62c9503addf63 (patch)
tree2ee0d5d147670d5a658cc8d588853d9f7cfc7bae /gnu/services/web.scm
parentadb3d8797d0521f3e08a9ecaff33f79ee4cead01 (diff)
downloadguix-a5daa8c0ab400bffc53f245069a62c9503addf63.tar.gz
guix-a5daa8c0ab400bffc53f245069a62c9503addf63.zip
gnu: Add julia-json3.
* gnu/packages/julia-xyz.scm (julia-json3): New variable.
Diffstat (limited to 'gnu/services/web.scm')
0 files changed, 0 insertions, 0 deletions