Fix 'scheme-indent-function' to indent s-expressions starting with a keyword properly, like this: (#:foo 1 #:bar 2) instead of like this: (#:foo 1 #:bar 2) The fix is made by Mark H Weaver : --- a/lisp/progmodes/scheme.el +++ b/lisp/progmodes/scheme.el @@ -482,6 +482,12 @@ (> (length function) 3) (string-match "\\`def" function))) (lisp-indent-defform state indent-point)) + ((and (null method) + (> (length function) 1) + ;; The '#' in '#:' seems to get lost, not sure why + (string-match "\\`:" function)) + (let ((lisp-body-indent 1)) + (lisp-indent-defform state indent-point))) ((integerp method) (lisp-indent-specform method state indent-point normal-indent)) ss='sub'>Wojtek's customized Guix aboutsummaryrefslogtreecommitdiff
2020-10-23
AgeCommit message (Expand)Author
2020-03-08services: guix-data-service: Allow passing extra options....Christopher Baines
2019-09-25services: Add the Guix Data Service....Christopher Baines
gnu: xournalpp: Update to 1.0.19....Nicolas Goaziou
2020-10-20gnu: poppler: Always use the same 'cairo-sans-poppler' variant....Ludovic Courtès
2020-10-15gnu: zathura: Update to 0.4.7....Michael Rohleder
2020-09-07gnu: xournalpp: Fix path to addr2line binary....Lars-Dominik Braun
2020-08-05gnu: stapler: Update to 1.0.0....Kei Kebreau
2020-07-29gnu: paps: Update description....Tobias Geerinckx-Rice
2020-07-12gnu: Remove ".git" from "https://github/…/….git"....Ludovic Courtès
2020-05-29Merge branch 'master' into stagingMarius Bakke