Do not capture the build-time value of $PATH in the 'emacs' executable since this can noticeably increase the size of the closure of Emacs with things like GCC being referenced. --- a/lisp/loadup.el +++ b/lisp/loadup.el @@ -530,7 +530,8 @@ lost after dumping"))) ((equal dump-mode "dump") "emacs") ((equal dump-mode "bootstrap") "emacs") ((equal dump-mode "pbootstrap") "bootstrap-emacs.pdmp") - (t (error "Unrecognized dump mode %s" dump-mode))))) + (t (error "Unrecognized dump mode %s" dump-mode)))) + (exec-path nil)) (when (and (featurep 'native-compile) (equal dump-mode "pdump")) ;; Don't enable this before bootstrap is completed, as the n value='koszko-scripts'>koszko-scripts Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/gnu/build/linux-boot.scm
AgeCommit message (Expand)Author
2022-09-04linux-boot: Resume from hibernation after pre-boot....Jack Hill
2022-03-01initrd: Honor rootfstype and rootflags command-line parameters....Maxim Cournoyer
2022-03-01initrd: Use non-hyphenated kernel command-line parameter names....Maxim Cournoyer
2022-02-17build: linux-boot: Expound docstring of the 'boot-system' procedure....Maxim Cournoyer
2021-09-23syscalls: Deduplicate device number conversion....Tobias Geerinckx-Rice
2021-09-23linux-boot: Honour fsck.mode & fsck.repair....Tobias Geerinckx-Rice
2021-09-23file-systems: Support forced checks & repairs....Tobias Geerinckx-Rice
2021-09-12linux-boot: Remove mummified comment....Tobias Geerinckx-Rice