Do not capture the build-time value of $PATH in the 'emacs' executable since this can noticeably increase the size of the closure of Emacs with things like GCC being referenced. --- a/lisp/loadup.el +++ b/lisp/loadup.el @@ -64,6 +64,11 @@ (expand-file-name "textmodes" dir) (expand-file-name "vc" dir))))) +;; Reset 'exec-path' so we don't capture the build-time $PATH in the +;; 'emacs' executable. +(setq-default exec-path nil) +(setq exec-path nil) + (if (eq t purify-flag) ;; Hash consing saved around 11% of pure space in my tests. (setq purify-flag (make-hash-table :test 'equal :size 70000))) ue='d20198347510094c809fb16f04181ae67b50a924'/> Wojtek's customized Guix
aboutsummaryrefslogtreecommitdiff
path: root/.dir-locals.el
AgeCommit message (Expand)Author
2020-12-15system: 'init' does not recompute the hash of each store item....Ludovic Courtès
2020-11-17Merge remote-tracking branch 'origin/version-1.2.0' into master...Maxim Cournoyer
2020-11-16.dir-locals.el: Add upstream report link....Miguel Ángel Arruga Vivas
2020-11-16.dir-locals.el: Use setq-local on guix-directory....Christopher Lemmer Webber
2020-11-16.dir-locals.el: Prevent errors if .dir-locals.el isn't found....Christopher Lemmer Webber
2020-11-12maint: update-guix-package: Optionally add sources to store....Maxim Cournoyer
2020-11-01.dir-locals.el: Require cl-lib at runtime....Miguel Ángel Arruga Vivas
2020-10-31.dir-locals.el: Automatically set the GEISER-GUILE-LOAD-PATH variable....Maxim Cournoyer
2020-10-19maint: update-guix-package: Prevent accidentally breaking guix pull....Maxim Cournoyer
2020-09-14deduplication: pass store directory to replace-with-link....Caleb Ristvedt
2020-09-14.dir-locals.el: fix call-with-{retrying-}transaction indenting....Caleb Ristvedt
2020-08-26.dir-locals.el: Add indentation rule for 'package/inherit'....Ludovic Courtès
2020-06-25deduplication: Use 'dynamic-wind' when changing permissions of the parent....Ludovic Courtès
2020-06-16channels: 'latest-channel-instance' authenticates Git checkouts....Ludovic Courtès