Index: emacs-29.2/src/comp.c
===================================================================
--- emacs-29.2.orig/src/comp.c
+++ emacs-29.2/src/comp.c
@@ -5648,8 +5648,12 @@ For internal use. */);
doc: /* If non-nil, compile loaded .elc files asynchronously.
After compilation, each function definition is updated to use the
-natively-compiled one. */);
- native_comp_jit_compilation = true;
+natively-compiled one. This variable is enabled by default upstream,
+but disabled in Guix to better make use of precompiled packages.
+Notably, Guix removes the hashes that prevent inadvertent shadowing
+frm the file names of compiled libraries in order to facilitate grafts.
+Enable at your own risk! */);
+ native_comp_jit_compilation = false;
DEFSYM (Qnative_comp_speed, "native-comp-speed");
DEFSYM (Qnative_comp_debug, "native-comp-debug");
>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2021-05-20 | The #guix channel is hosted by Libera Chat....* README (Contact): Update network name.
* ROADMAP: Likewise.
* doc/contributing.texi (Contributing): Likewise.
* doc/guix.texi (After System Installation): Likewise.
| Tobias Geerinckx-Rice |
2020-10-23 | doc: Update README....* README (Installation): Do not mention installing Guix from Git anymore.
(Building from Git): Add section.
| Maxim Cournoyer |
2020-10-22 | README: Refer to the manual for building from Git....* README (Installing Guix from Guix): Remove section.
(Installation): For installing from Git, refer to the "Building from Git"
section of the manual and suggest using './pre-inst-env guix pull' rather than
'make install' for installing Guix.
| Maxim Cournoyer |