Index: emacs-29.2/src/comp.c
===================================================================
--- emacs-29.2.orig/src/comp.c
+++ emacs-29.2/src/comp.c
@@ -5648,8 +5648,12 @@ For internal use. */);
doc: /* If non-nil, compile loaded .elc files asynchronously.
After compilation, each function definition is updated to use the
-natively-compiled one. */);
- native_comp_jit_compilation = true;
+natively-compiled one. This variable is enabled by default upstream,
+but disabled in Guix to better make use of precompiled packages.
+Notably, Guix removes the hashes that prevent inadvertent shadowing
+frm the file names of compiled libraries in order to facilitate grafts.
+Enable at your own risk! */);
+ native_comp_jit_compilation = false;
DEFSYM (Qnative_comp_speed, "native-comp-speed");
DEFSYM (Qnative_comp_debug, "native-comp-debug");
='switch'/>
Wojtek's customized Guix | |
Age | Commit message (Expand) | Author |
2024-08-31 | gnu: cdrom: Add 'bash' input for 'wrap-program'....It is required for cross-compilation.
* gnu/packages/cdrom.scm
(xorisso)[inputs]: Add 'bash-minimal'.
(dvdstyler)[inputs]: Likewise.
(abcde)[inputs]: Likewise.
(asunder)[inputs]: Likewise.
(cdemu-client)[inputs]: Likewise.
Signed-off-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Modified-by: Maxim Cournoyer <maxim.cournoyer@gmail.com>
Change-Id: I262c4dd2c81ec6558e7b48b7436268c9656933ca
| Maxime Devos |
2023-12-28 | gnu: cdparanoia: Fix cross-compiling....* gnu/packages/cdrom.scm (cdparanoia)
[native-inputs]: when cross compiling to {riscv,aarch}64-linux-gnu, add config.
[arguments]: when target {riscv,aarch}64-linux-gnu, add update-config-scripts phase.
<#:configure-flags>: when cross-compiling, use `(assoc-ref %outputs "out")'.
Change-Id: I442c668c3d52c241f0d405f51ea8d995bfefd3fd
Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
| Zheng Junjie |
2023-11-19 | gnu: libmirage: Update to 3.2.7....* gnu/packages/cdrom.scm (libmirage): Update to 3.2.7.
Change-Id: Ib4d62bbbcb4bedd2ce86f6d5262df6ed26c76cee
| Tobias Geerinckx-Rice |