From 3c0f4b27a079b90dc632f5061a81ce28cef24801 Mon Sep 17 00:00:00 2001 From: eryx67 Date: Thu, 29 Nov 2018 10:30:20 +0500 Subject: [PATCH] fix for latest emacs --- dired-toggle-sudo.el | 11 +++++++---- 1 file changed, 7 insertions(+), 4 deletions(-) diff --git a/dired-toggle-sudo.el b/dired-toggle-sudo.el index 386921b..fe5898e 100644 --- a/dired-toggle-sudo.el +++ b/dired-toggle-sudo.el @@ -37,17 +37,20 @@ unless SUDO-USER is provided." (let* (;; Handle the case of local files. `tramp-dissect-file-name' does ;; not raise an error anymore. - (path (if (tramp-tramp-file-p path) path (concat "/:" path))) + ;;(path (if (tramp-tramp-file-p path) path (concat "/-::" path))) (file-vec (or (ignore-errors (tramp-dissect-file-name path)) (tramp-dissect-file-name - (concat "/:" path) 1))) + (concat "/-::" path) 1))) (method (tramp-file-name-method file-vec)) (user (tramp-file-name-user file-vec)) (host (tramp-file-name-host file-vec)) + (domain (tramp-file-name-domain file-vec)) + (port (tramp-file-name-port file-vec)) (localname (expand-file-name (tramp-file-name-localname file-vec)))) - (when (string= system-name host) + (when (or (string= (system-name) host) + (string= "-" host)) (setq host nil)) (cond ;; remote directory -> sudo @@ -67,7 +70,7 @@ unless SUDO-USER is provided." (setq method "sudo" user sudo-user))) (replace-regexp-in-string "^/:/" "/" - (tramp-make-tramp-file-name method user host localname)))) + (tramp-make-tramp-file-name method domain user host port localname)))) (defun dired-toggle-sudo-find (fname) "Create a new buffer for file name FNAME." -- 2.22.0 p'>log msg
path: root/.guix-authorizations
diff options
context:
space:
mode:
authorW. Kosior <koszko@koszko.org>2024-09-04 20:50:17 +0200
committerW. Kosior <koszko@koszko.org>2024-09-04 21:02:12 +0200
commit4aad2dedac15c2f3c9b427dc8a9ae2992e963a16 (patch)
tree411805075d209d8e3c21315128b8e9b70908d2eb /.guix-authorizations
parentda83e21c97b644f823b75ad92e1c51e82452abc9 (diff)
downloadguix-4aad2dedac15c2f3c9b427dc8a9ae2992e963a16.tar.gz
guix-4aad2dedac15c2f3c9b427dc8a9ae2992e963a16.zip
services: Allow specifying user and group for knot resolver.
Kresd used to start as root and create cache files with root ownership before dropping privileges. This made unprivileged kres-cache-gc (in a separate service) fail when trying to read them. The new default is to start both as `knot-resolver', with configuration fields that allow overriding this default. * gnu/services/dns.scm (<knot-resolver-configuration>)[user]: New field. (<knot-resolver-configuration>)[group]: New field. (knot-resolver-shepherd-services): Pass the user&group from config to forkexec constructors. Change-Id: Id06a8eca140fdca14995a03e910f521d5f4636e5
Diffstat (limited to '.guix-authorizations')
0 files changed, 0 insertions, 0 deletions