commit e3512d887df41a8162c3e361171c04beca08415b Author: Tom Stejskal Date: Mon Nov 19 20:09:43 2018 +0100 Fix Map.!: given key is not an element in the map diff --git a/compiler/src/Elm/Compiler/Type/Extract.hs b/compiler/src/Elm/Compiler/Type/Extract.hs index 1aafe1d4..99763392 100644 --- a/compiler/src/Elm/Compiler/Type/Extract.hs +++ b/compiler/src/Elm/Compiler/Type/Extract.hs @@ -10,6 +10,7 @@ module Elm.Compiler.Type.Extract import Data.Map ((!)) +import qualified Data.Map as Map import qualified Data.Maybe as Maybe import qualified Data.Set as Set @@ -134,11 +135,15 @@ extractUnion interfaces (Opt.Global home name) = else let pname = toPublicName home name - unions = I._unions (interfaces ! home) + maybeUnions = I._unions <$> Map.lookup home interfaces in - case I.toUnionInternals (unions ! name) of - Can.Union vars ctors _ _ -> - T.Union pname vars <$> traverse extractCtor ctors + case Map.lookup name =<< maybeUnions of + Just union -> + case I.toUnionInternals union of + Can.Union vars ctors _ _ -> + T.Union pname vars <$> traverse extractCtor ctors + Nothing -> + return $ T.Union pname [] [] extractCtor :: Can.Ctor -> Extractor (N.Name, [T.Type]) 53e4'>treecommitdiff
path: root/doc/htmlxref.cnf
AgeCommit message (Collapse)Author
2022-12-18doc: Update URLs for the manual and cookbook translations.Ludovic Courtès
* doc/htmlxref.cnf: Update URLs for "guix" and "guix-cookbook".
2022-12-18doc: Add guile-netlink to 'htmlxref.cnf'.Ludovic Courtès
* doc/htmlxref.cnf: Add guile-netlink.
2022-08-05doc: Fix Guix manual URLs in 'htmlxref.cnf'.Ludovic Courtès
Fixes a regression introduced in 868da34d54365023223a4ff7520043ba55ad64e8. * doc/htmlxref.cnf (GUIX): Remove "/guix".
2022-06-16doc: Remove obsolete comment from htmlxref.cnf.Maxim Cournoyer
This is follow up to <https://issues.guix.gnu.org/55290>. * doc/htmlxref.cnf (geiser): Delete obsolete comment.
2022-04-08doc: Fix cookbook URLs in htmlxref.cnf.Ludovic Courtès
Reported by Greg Hogan <code@greghogan.com>. * doc/htmlxref.cnf (GUIX_ROOT): New variable. (GUIX, GUIX_COOKBOOK): Adjust.
2021-10-04doc: Update htmlxref.cnf.Sarah Morgensen
Update and fix broken references to cuirass, git, and guix-cookbook. * doc/htmlxref.cnf: Update from Texinfo. Factorize Guix manuals. (cuirass, git, guix-cookbook, guix-cookbook.de, guix-cookbook.fr): New entries. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
2021-04-24doc: Fix cross-reference URL to translated manual.Julien Lepiller
* doc/htmlxref.cnf: Fix translated manual URL.
2020-01-12doc: Update htmlxref.cnf.Ludovic Courtès
* doc/htmlxref.cnf: Update from Texinfo. Add entries for "mes", "guix.ru", and "guix.zh_CN".
2019-05-04doc: Update htmlxref.cnf.Ludovic Courtès
* doc/htmlxref.cnf (G): Switch to https. (geiser, guix.de, guix.es, hurd): New entries.