commit 20d80e2323b565a36751c9455e535d8f73fa32f7 Author: Robert Vollmert Date: Fri Jun 14 16:05:47 2019 +0200 disable reactor diff --git a/elm.cabal b/elm.cabal index c75f9689..ece63c46 100644 --- a/elm.cabal +++ b/elm.cabal @@ -45,9 +45,6 @@ Executable elm builder/src ui/terminal/src - other-extensions: - TemplateHaskell - Main-Is: Main.hs @@ -56,8 +53,6 @@ Executable elm Develop Develop.Generate.Help Develop.Generate.Index - Develop.StaticFiles - Develop.StaticFiles.Build Diff Init Install diff --git a/ui/terminal/src/Develop.hs b/ui/terminal/src/Develop.hs index 4b2252e1..7ed7716e 100644 --- a/ui/terminal/src/Develop.hs +++ b/ui/terminal/src/Develop.hs @@ -23,7 +23,6 @@ import Snap.Util.FileServe import qualified Elm.Project as Project import qualified Develop.Generate.Help as Generate import qualified Develop.Generate.Index as Index -import qualified Develop.StaticFiles as StaticFiles import qualified Generate.Output as Output import qualified Json.Encode as Encode import qualified Reporting.Exit as Exit @@ -219,16 +218,7 @@ compileToHtmlBuilder mode file = serveAssets :: Snap () -serveAssets = - do file <- getSafePath - case StaticFiles.lookup file of - Nothing -> - pass - - Just (content, mimeType) -> - do modifyResponse (setContentType (mimeType <> ";charset=utf-8")) - writeBS content - +serveAssets = pass -- MIME TYPES diff --git a/ui/terminal/src/Main.hs b/terminal/src/Main.hs index 7000f3ca..2c76965a 100644 --- a/ui/terminal/src/Main.hs +++ b/ui/terminal/src/Main.hs @@ -39,7 +39,6 @@ main = complex intro outro [ repl , init - , reactor , make , install , bump lue=''/>
path: root/gnu/tests.scm
r>
AgeCommit message (Expand)Author
2020-03-05tests: Add <system-test> gexp compiler....Ludovic Courtès
2020-01-23tests: Fix typo in comment....Ludovic Courtès
2019-12-18gexp: Allow character literals in GEXP->SEXP....Marius Bakke
2019-09-23repl, marionette: 'self-quoting?' matches keywords....Ludovic Courtès
2019-03-25accounts: Add default value for the 'home-directory' field of <user-account>....Ludovic Courtès
2020-07-28pack: "fakechroot" engine always creates its store....Ludovic Courtès
2020-07-28pack: "fakechroot" execution engine can load its audit module....Ludovic Courtès
2020-05-14pack: Add relocation via ld.so and fakechroot....Ludovic Courtès
2020-05-14pack: Factorize store references in wrapper....Ludovic Courtès
2020-05-14pack: Wrapper honors 'GUIX_EXECUTION_ENGINE' environment variable....Ludovic Courtès
2020-05-07pack: Factorize 'exec_in_user_namespace' wrapper....Ludovic Courtès
2020-05-07pack: Add 'xmalloc' in wrapper....Ludovic Courtès
2020-05-07pack: Fix off-by-one in PRoot handling in the wrapper....Ludovic Courtès
2020-04-24pack: 'guix pack -R' wrapper correctly reports exit code....Ludovic Courtès